blob: add45765d6a172c6cc63b7df858f8b4ce49a20f2 [file] [log] [blame]
willy tarreau9974d732006-04-15 21:47:17 +02001Summary: HA-Proxy is a TCP/HTTP reverse proxy for high availability environments
2Name: haproxy
Willy Tarreau9ca931f2007-05-10 07:51:17 +02003Version: 1.3.10.2
willy tarreau9974d732006-04-15 21:47:17 +02004Release: 1
5License: GPL
6Group: System Environment/Daemons
Willy Tarreau1e443e92007-04-01 11:37:02 +02007URL: http://haproxy.1wt.eu/
8Source0: http://haproxy.1wt.eu/download/1.3/src/%{name}-%{version}.tar.gz
willy tarreau9974d732006-04-15 21:47:17 +02009BuildRoot: %{_tmppath}/%{name}-%{version}-root
10BuildRequires: pcre-devel
11Requires: /sbin/chkconfig, /sbin/service
12
13%description
14HA-Proxy is a TCP/HTTP reverse proxy which is particularly suited for high
15availability environments. Indeed, it can:
16- route HTTP requests depending on statically assigned cookies
17- spread the load among several servers while assuring server persistence
18 through the use of HTTP cookies
19- switch to backup servers in the event a main one fails
20- accept connections to special ports dedicated to service monitoring
21- stop accepting connections without breaking existing ones
22- add/modify/delete HTTP headers both ways
23- block requests matching a particular pattern
24
25It needs very little resource. Its event-driven architecture allows it to easily
26handle thousands of simultaneous connections on hundreds of instances without
27risking the system's stability.
28
29%prep
30%setup -q
31
32%build
33%{__make} REGEX="pcre" "COPTS.pcre=-DUSE_PCRE $(pcre-config --cflags)" DEBUG="" TARGET=linux24e SMALL_OPTS="-DBUFSIZE=8030 -DMAXREWRITE=1030 -DSYSTEM_MAXCONN=1024" DEBUG="" LIBS.pcre="-L\$(PCREDIR)/lib -Wl,-Bstatic -lpcreposix -lpcre -Wl,-Bdynamic"
34
35%install
36[ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
37
38%{__install} -d %{buildroot}%{_sbindir}
39%{__install} -d %{buildroot}%{_sysconfdir}/rc.d/init.d
40%{__install} -d %{buildroot}%{_sysconfdir}/%{name}
41
42%{__install} -s %{name} %{buildroot}%{_sbindir}/
43%{__install} -c -m 644 examples/%{name}.cfg %{buildroot}%{_sysconfdir}/%{name}/
44%{__install} -c -m 755 examples/%{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
45
46%clean
47[ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
48
49%post
50/sbin/chkconfig --add %{name}
51
52%preun
53if [ $1 = 0 ]; then
54 /sbin/service %{name} stop >/dev/null 2>&1 || :
55 /sbin/chkconfig --del %{name}
56fi
57
58%postun
59if [ "$1" -ge "1" ]; then
60 /sbin/service %{name} condrestart >/dev/null 2>&1 || :
61fi
62
63%files
64%defattr(-,root,root)
Willy Tarreau6bbf14c2006-07-09 09:08:05 +020065%doc CHANGELOG TODO examples doc/haproxy-en.txt doc/haproxy-fr.txt doc/architecture.txt examples/url-switching.cfg
willy tarreau9974d732006-04-15 21:47:17 +020066%attr(0755,root,root) %{_sbindir}/%{name}
67%dir %{_sysconfdir}/%{name}
68%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/%{name}.cfg
69%attr(0755,root,root) %config %{_sysconfdir}/rc.d/init.d/%{name}
70
71%changelog
Willy Tarreau9ca931f2007-05-10 07:51:17 +020072* Thu May 10 2007 Willy Tarreau <w@1wt.eu>
73- updated to 1.3.10.2
74
Willy Tarreau13398d32007-05-09 22:58:28 +020075* Tue May 09 2007 Willy Tarreau <w@1wt.eu>
76- updated to 1.3.10.1
77
Willy Tarreau61beedf2007-05-09 01:44:58 +020078* Tue May 08 2007 Willy Tarreau <w@1wt.eu>
79- updated to 1.3.10
80
Willy Tarreau6e0433f2007-04-16 01:18:12 +020081* Sun Apr 15 2007 Willy Tarreau <w@1wt.eu>
82- updated to 1.3.9
83
Willy Tarreau42c76592007-04-03 20:30:13 +020084* Tue Apr 03 2007 Willy Tarreau <w@1wt.eu>
85- updated to 1.3.8.2
86
Willy Tarreauef6d7612007-04-01 11:06:22 +020087* Sun Apr 01 2007 Willy Tarreau <w@1wt.eu>
88- updated to 1.3.8.1
89
Willy Tarreaud661cc02007-03-26 00:24:56 +020090* Sun Mar 25 2007 Willy Tarreau <w@1wt.eu>
91- updated to 1.3.8
92
Willy Tarreau9cabf702007-01-26 23:49:01 +010093* Wed Jan 26 2007 Willy Tarreau <w@1wt.eu>
94- updated to 1.3.7
95
Willy Tarreau49e1ee82007-01-22 00:56:46 +010096* Wed Jan 22 2007 Willy Tarreau <w@1wt.eu>
97- updated to 1.3.6
98
Willy Tarreau5871f8e2007-01-07 02:47:01 +010099* Wed Jan 07 2007 Willy Tarreau <w@1wt.eu>
100- updated to 1.3.5
101
Willy Tarreau85270da2007-01-02 00:59:39 +0100102* Wed Jan 02 2007 Willy Tarreau <w@1wt.eu>
103- updated to 1.3.4
104
Willy Tarreau9c9fea42006-10-16 00:03:35 +0200105* Wed Oct 15 2006 Willy Tarreau <w@1wt.eu>
106- updated to 1.3.3
107
Willy Tarreau690f9aa2006-09-03 11:23:06 +0200108* Wed Sep 03 2006 Willy Tarreau <w@1wt.eu>
109- updated to 1.3.2
110
Willy Tarreau8f2b8552006-07-09 17:11:39 +0200111* Wed Jul 09 2006 Willy Tarreau <w@1wt.eu>
112- updated to 1.3.1
113
willy tarreau7e6328d2006-05-21 23:26:20 +0200114* Wed May 21 2006 Willy Tarreau <willy@w.ods.org>
115- updated to 1.2.14
116
willy tarreauc3a2e072006-05-13 18:51:38 +0200117* Wed May 01 2006 Willy Tarreau <willy@w.ods.org>
118- updated to 1.2.13
119
willy tarreau9974d732006-04-15 21:47:17 +0200120* Wed Apr 15 2006 Willy Tarreau <willy@w.ods.org>
121- updated to 1.2.12
122
123* Wed Mar 30 2006 Willy Tarreau <willy@w.ods.org>
124- updated to 1.2.11.1
125
126* Wed Mar 19 2006 Willy Tarreau <willy@w.ods.org>
127- updated to 1.2.10
128
129* Wed Mar 15 2006 Willy Tarreau <willy@w.ods.org>
130- updated to 1.2.9
131
132* Sat Jan 22 2005 Willy Tarreau <willy@w.ods.org>
133- updated to 1.2.3 (1.1.30)
134
135* Sun Nov 14 2004 Willy Tarreau <w@w.ods.org>
136- updated to 1.1.29
137- fixed path to config and init files
138- statically linked PCRE to increase portability to non-pcre systems
139
140* Sun Jun 6 2004 Willy Tarreau <willy@w.ods.org>
141- updated to 1.1.28
142- added config check support to the init script
143
144* Tue Oct 28 2003 Simon Matter <simon.matter@invoca.ch>
145- updated to 1.1.27
146- added pid support to the init script
147
148* Wed Oct 22 2003 Simon Matter <simon.matter@invoca.ch>
149- updated to 1.1.26
150
151* Thu Oct 16 2003 Simon Matter <simon.matter@invoca.ch>
152- initial build