blob: f41a389ae5ac30c484ea73f4698afc0eefb6c315 [file] [log] [blame]
willy tarreau9974d732006-04-15 21:47:17 +02001Summary: HA-Proxy is a TCP/HTTP reverse proxy for high availability environments
2Name: haproxy
Willy Tarreau85270da2007-01-02 00:59:39 +01003Version: 1.3.4
willy tarreau9974d732006-04-15 21:47:17 +02004Release: 1
5License: GPL
6Group: System Environment/Daemons
7URL: http://w.ods.org/tools/%{name}/
8Source0: http://w.ods.org/tools/%{name}/%{name}-%{version}.tar.gz
9BuildRoot: %{_tmppath}/%{name}-%{version}-root
10BuildRequires: pcre-devel
11Requires: /sbin/chkconfig, /sbin/service
12
13%description
14HA-Proxy is a TCP/HTTP reverse proxy which is particularly suited for high
15availability environments. Indeed, it can:
16- route HTTP requests depending on statically assigned cookies
17- spread the load among several servers while assuring server persistence
18 through the use of HTTP cookies
19- switch to backup servers in the event a main one fails
20- accept connections to special ports dedicated to service monitoring
21- stop accepting connections without breaking existing ones
22- add/modify/delete HTTP headers both ways
23- block requests matching a particular pattern
24
25It needs very little resource. Its event-driven architecture allows it to easily
26handle thousands of simultaneous connections on hundreds of instances without
27risking the system's stability.
28
29%prep
30%setup -q
31
32%build
33%{__make} REGEX="pcre" "COPTS.pcre=-DUSE_PCRE $(pcre-config --cflags)" DEBUG="" TARGET=linux24e SMALL_OPTS="-DBUFSIZE=8030 -DMAXREWRITE=1030 -DSYSTEM_MAXCONN=1024" DEBUG="" LIBS.pcre="-L\$(PCREDIR)/lib -Wl,-Bstatic -lpcreposix -lpcre -Wl,-Bdynamic"
34
35%install
36[ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
37
38%{__install} -d %{buildroot}%{_sbindir}
39%{__install} -d %{buildroot}%{_sysconfdir}/rc.d/init.d
40%{__install} -d %{buildroot}%{_sysconfdir}/%{name}
41
42%{__install} -s %{name} %{buildroot}%{_sbindir}/
43%{__install} -c -m 644 examples/%{name}.cfg %{buildroot}%{_sysconfdir}/%{name}/
44%{__install} -c -m 755 examples/%{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
45
46%clean
47[ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
48
49%post
50/sbin/chkconfig --add %{name}
51
52%preun
53if [ $1 = 0 ]; then
54 /sbin/service %{name} stop >/dev/null 2>&1 || :
55 /sbin/chkconfig --del %{name}
56fi
57
58%postun
59if [ "$1" -ge "1" ]; then
60 /sbin/service %{name} condrestart >/dev/null 2>&1 || :
61fi
62
63%files
64%defattr(-,root,root)
Willy Tarreau6bbf14c2006-07-09 09:08:05 +020065%doc CHANGELOG TODO examples doc/haproxy-en.txt doc/haproxy-fr.txt doc/architecture.txt examples/url-switching.cfg
willy tarreau9974d732006-04-15 21:47:17 +020066%attr(0755,root,root) %{_sbindir}/%{name}
67%dir %{_sysconfdir}/%{name}
68%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/%{name}.cfg
69%attr(0755,root,root) %config %{_sysconfdir}/rc.d/init.d/%{name}
70
71%changelog
Willy Tarreau5871f8e2007-01-07 02:47:01 +010072* Wed Jan 07 2007 Willy Tarreau <w@1wt.eu>
73- updated to 1.3.5
74
Willy Tarreau85270da2007-01-02 00:59:39 +010075* Wed Jan 02 2007 Willy Tarreau <w@1wt.eu>
76- updated to 1.3.4
77
Willy Tarreau9c9fea42006-10-16 00:03:35 +020078* Wed Oct 15 2006 Willy Tarreau <w@1wt.eu>
79- updated to 1.3.3
80
Willy Tarreau690f9aa2006-09-03 11:23:06 +020081* Wed Sep 03 2006 Willy Tarreau <w@1wt.eu>
82- updated to 1.3.2
83
Willy Tarreau8f2b8552006-07-09 17:11:39 +020084* Wed Jul 09 2006 Willy Tarreau <w@1wt.eu>
85- updated to 1.3.1
86
willy tarreau7e6328d2006-05-21 23:26:20 +020087* Wed May 21 2006 Willy Tarreau <willy@w.ods.org>
88- updated to 1.2.14
89
willy tarreauc3a2e072006-05-13 18:51:38 +020090* Wed May 01 2006 Willy Tarreau <willy@w.ods.org>
91- updated to 1.2.13
92
willy tarreau9974d732006-04-15 21:47:17 +020093* Wed Apr 15 2006 Willy Tarreau <willy@w.ods.org>
94- updated to 1.2.12
95
96* Wed Mar 30 2006 Willy Tarreau <willy@w.ods.org>
97- updated to 1.2.11.1
98
99* Wed Mar 19 2006 Willy Tarreau <willy@w.ods.org>
100- updated to 1.2.10
101
102* Wed Mar 15 2006 Willy Tarreau <willy@w.ods.org>
103- updated to 1.2.9
104
105* Sat Jan 22 2005 Willy Tarreau <willy@w.ods.org>
106- updated to 1.2.3 (1.1.30)
107
108* Sun Nov 14 2004 Willy Tarreau <w@w.ods.org>
109- updated to 1.1.29
110- fixed path to config and init files
111- statically linked PCRE to increase portability to non-pcre systems
112
113* Sun Jun 6 2004 Willy Tarreau <willy@w.ods.org>
114- updated to 1.1.28
115- added config check support to the init script
116
117* Tue Oct 28 2003 Simon Matter <simon.matter@invoca.ch>
118- updated to 1.1.27
119- added pid support to the init script
120
121* Wed Oct 22 2003 Simon Matter <simon.matter@invoca.ch>
122- updated to 1.1.26
123
124* Thu Oct 16 2003 Simon Matter <simon.matter@invoca.ch>
125- initial build