[RELEASE] Released version 1.3.9 with the following changes :
- modularized the polling mechanisms and use function pointers instead
of macros at many places
- implemented support for FreeBSD's kqueue() polling mechanism
- fixed a warning on OpenBSD : MIN/MAX redefined
- change socket registration order at startup to accomodate kqueue.
- several makefile cleanups to support old shells
- fix build with limits.h once for all
- ev_epoll: do not rely on fd_sets anymore, use changes stacks instead.
- fdtab now holds the results of polling
- implemented support for speculative I/O processing with epoll()
- remove useless calls to shutdown(SHUT_RD), resulting in small speed boost
- auto-registering of pollers at load time
diff --git a/examples/haproxy-small.spec b/examples/haproxy-small.spec
index f0c872c..42c6264 100644
--- a/examples/haproxy-small.spec
+++ b/examples/haproxy-small.spec
@@ -1,6 +1,6 @@
Summary: HA-Proxy is a TCP/HTTP reverse proxy for high availability environments
Name: haproxy
-Version: 1.3.8.2
+Version: 1.3.9
Release: 1
License: GPL
Group: System Environment/Daemons
@@ -69,6 +69,9 @@
%attr(0755,root,root) %config %{_sysconfdir}/rc.d/init.d/%{name}
%changelog
+* Sun Apr 15 2007 Willy Tarreau <w@1wt.eu>
+- updated to 1.3.9
+
* Tue Apr 03 2007 Willy Tarreau <w@1wt.eu>
- updated to 1.3.8.2