blob: c450aa18b1b3fe0e8664621b2e35a45b188d1754 [file] [log] [blame]
developer15a43312022-04-12 11:23:23 +08001FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI += " \
4 file://lighttpd_php.conf.broadband \
5 file://lighttpd_jst.conf.broadband \
6"
7
8SYSTEMD_SERVICE_${PN} += "lighttpd.service"
9
10do_install_append() {
11 install -d ${D}${sysconfdir}
12 if [ "${@bb.utils.contains("DISTRO_FEATURES", "webui_jst", "yes", "no", d)}" = "yes" ]; then
13 install -m 0644 ${WORKDIR}/lighttpd_jst.conf.broadband ${D}${sysconfdir}/lighttpd.conf
14 else
15 install -m 0644 ${WORKDIR}/lighttpd_php.conf.broadband ${D}${sysconfdir}/lighttpd.conf
16 fi
17}
18
19FILES_${PN}_append_morty = " /usr/lib/mod_fastcgi.so"
20
21RDEPENDS_${PN}_append_dunfell = " \
22 lighttpd-module-fastcgi \
23 lighttpd-module-proxy \
24 "