[Add meta-cmf-filogic sdk cmf for rdkb development]
[Description]
Add meta-cmf-filogic sdk cmf for rdkb development
1. rdkb base on dunfell rdkb-next (> 2022q1)
2. cmf is mostly from meta-turris implementation
3. some 64bit support are port from rp4-64 cmf
4. arm64/arm 32bit bsp both can run on rdkb
[Release-log]
N/A
diff --git a/recipes-extended/lighttpd/lighttpd_%.bbappend b/recipes-extended/lighttpd/lighttpd_%.bbappend
new file mode 100644
index 0000000..c450aa1
--- /dev/null
+++ b/recipes-extended/lighttpd/lighttpd_%.bbappend
@@ -0,0 +1,24 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += " \
+ file://lighttpd_php.conf.broadband \
+ file://lighttpd_jst.conf.broadband \
+"
+
+SYSTEMD_SERVICE_${PN} += "lighttpd.service"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}
+ if [ "${@bb.utils.contains("DISTRO_FEATURES", "webui_jst", "yes", "no", d)}" = "yes" ]; then
+ install -m 0644 ${WORKDIR}/lighttpd_jst.conf.broadband ${D}${sysconfdir}/lighttpd.conf
+ else
+ install -m 0644 ${WORKDIR}/lighttpd_php.conf.broadband ${D}${sysconfdir}/lighttpd.conf
+ fi
+}
+
+FILES_${PN}_append_morty = " /usr/lib/mod_fastcgi.so"
+
+RDEPENDS_${PN}_append_dunfell = " \
+ lighttpd-module-fastcgi \
+ lighttpd-module-proxy \
+ "