developer | 15a4331 | 2022-04-12 11:23:23 +0800 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" |
| 2 | |
| 3 | SRC_URI += " \ |
| 4 | file://lighttpd_php.conf.broadband \ |
| 5 | file://lighttpd_jst.conf.broadband \ |
| 6 | " |
| 7 | |
| 8 | SYSTEMD_SERVICE_${PN} += "lighttpd.service" |
| 9 | |
| 10 | do_install_append() { |
| 11 | install -d ${D}${sysconfdir} |
| 12 | if [ "${@bb.utils.contains("DISTRO_FEATURES", "webui_jst", "yes", "no", d)}" = "yes" ]; then |
| 13 | install -m 0644 ${WORKDIR}/lighttpd_jst.conf.broadband ${D}${sysconfdir}/lighttpd.conf |
| 14 | else |
| 15 | install -m 0644 ${WORKDIR}/lighttpd_php.conf.broadband ${D}${sysconfdir}/lighttpd.conf |
| 16 | fi |
| 17 | } |
| 18 | |
| 19 | FILES_${PN}_append_morty = " /usr/lib/mod_fastcgi.so" |
| 20 | |
| 21 | RDEPENDS_${PN}_append_dunfell = " \ |
| 22 | lighttpd-module-fastcgi \ |
| 23 | lighttpd-module-proxy \ |
| 24 | " |