developer | 15a4331 | 2022-04-12 11:23:23 +0800 | [diff] [blame] | 1 | SUMMARY = "CCSP Utopia" |
| 2 | HOMEPAGE = "http://github.com/belvedere-yocto/Utopia" |
| 3 | |
| 4 | LICENSE = "Apache-2.0 & BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=baa21dec03307f641a150889224a157f" |
| 6 | SRC_URI = "${CMF_GIT_ROOT}/rdkb/components/opensource/ccsp/Utopia;protocol=${CMF_GIT_PROTOCOL};branch=${CMF_GIT_BRANCH};name=Utopia" |
| 7 | |
| 8 | SRCREV_Utopia = "${AUTOREV}" |
| 9 | PV = "${RDK_RELEASE}" |
| 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | # this is a header package only, nothing to build |
| 14 | do_compile[noexec] = "1" |
| 15 | do_configure[noexec] = "1" |
| 16 | |
| 17 | # also get rid of the default dependency added in bitbake.conf |
| 18 | # since there is no 'main' package generated (empty) |
| 19 | RDEPENDS_${PN}-dev = "" |
| 20 | |
| 21 | do_install() { |
| 22 | install -D -m 0644 ${S}/source/include/autoconf.h ${D}${includedir}/utctx/autoconf.h |
| 23 | install -D -m 0644 ${S}/source/utctx/lib/utctx.h ${D}${includedir}/utctx/utctx.h |
| 24 | install -D -m 0644 ${S}/source/utctx/lib/utctx_api.h ${D}${includedir}/utctx/utctx_api.h |
| 25 | install -D -m 0644 ${S}/source/utctx/lib/utctx_rwlock.h ${D}${includedir}/utctx/utctx_rwlock.h |
| 26 | } |