[Add meta-cmf-filogic sdk cmf for rdkb development]

[Description]
Add meta-cmf-filogic sdk cmf for rdkb development
1. rdkb base on dunfell rdkb-next (> 2022q1)
2. cmf is mostly from meta-turris implementation
3. some 64bit support are port from rp4-64 cmf
4. arm64/arm 32bit bsp both can run on rdkb

[Release-log]
N/A

diff --git a/recipes-ccsp/util/utopia-headers.bb b/recipes-ccsp/util/utopia-headers.bb
new file mode 100644
index 0000000..1d14402
--- /dev/null
+++ b/recipes-ccsp/util/utopia-headers.bb
@@ -0,0 +1,26 @@
+SUMMARY = "CCSP Utopia"
+HOMEPAGE = "http://github.com/belvedere-yocto/Utopia"
+
+LICENSE = "Apache-2.0 & BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=baa21dec03307f641a150889224a157f"
+SRC_URI = "${CMF_GIT_ROOT}/rdkb/components/opensource/ccsp/Utopia;protocol=${CMF_GIT_PROTOCOL};branch=${CMF_GIT_BRANCH};name=Utopia"
+
+SRCREV_Utopia = "${AUTOREV}"
+PV = "${RDK_RELEASE}"
+
+S = "${WORKDIR}/git"
+
+# this is a header package only, nothing to build
+do_compile[noexec] = "1"
+do_configure[noexec] = "1"
+
+# also get rid of the default dependency added in bitbake.conf
+# since there is no 'main' package generated (empty)
+RDEPENDS_${PN}-dev = ""
+
+do_install() {
+    install -D -m 0644 ${S}/source/include/autoconf.h ${D}${includedir}/utctx/autoconf.h
+    install -D -m 0644 ${S}/source/utctx/lib/utctx.h ${D}${includedir}/utctx/utctx.h
+    install -D -m 0644 ${S}/source/utctx/lib/utctx_api.h ${D}${includedir}/utctx/utctx_api.h
+    install -D -m 0644 ${S}/source/utctx/lib/utctx_rwlock.h ${D}${includedir}/utctx/utctx_rwlock.h
+}