blob: f45abe59b18a552d8dc5ee785d5a68c6e4ec673b [file] [log] [blame]
willy tarreau982249e2005-12-18 00:57:06 +01001Summary: HA-Proxy is a TCP/HTTP reverse proxy for high availability environments
2Name: haproxy
Willy Tarreaue855f422007-10-18 22:38:22 +02003Version: 1.3.13
willy tarreau982249e2005-12-18 00:57:06 +01004Release: 1
5License: GPL
6Group: System Environment/Daemons
Willy Tarreau1e443e92007-04-01 11:37:02 +02007URL: http://haproxy.1wt.eu/
8Source0: http://haproxy.1wt.eu/download/1.3/src/%{name}-%{version}.tar.gz
willy tarreaue4c2e102006-03-15 20:47:25 +01009BuildRoot: %{_tmppath}/%{name}-%{version}-root
willy tarreau982249e2005-12-18 00:57:06 +010010BuildRequires: pcre-devel
willy tarreaub6da4792006-03-15 19:41:10 +010011Requires: /sbin/chkconfig, /sbin/service
willy tarreau982249e2005-12-18 00:57:06 +010012
13%description
14HA-Proxy is a TCP/HTTP reverse proxy which is particularly suited for high
15availability environments. Indeed, it can:
16- route HTTP requests depending on statically assigned cookies
17- spread the load among several servers while assuring server persistence
18 through the use of HTTP cookies
19- switch to backup servers in the event a main one fails
20- accept connections to special ports dedicated to service monitoring
21- stop accepting connections without breaking existing ones
22- add/modify/delete HTTP headers both ways
23- block requests matching a particular pattern
24
25It needs very little resource. Its event-driven architecture allows it to easily
26handle thousands of simultaneous connections on hundreds of instances without
27risking the system's stability.
28
29%prep
willy tarreaue4c2e102006-03-15 20:47:25 +010030%setup -q
willy tarreau982249e2005-12-18 00:57:06 +010031
32%build
willy tarreaub6da4792006-03-15 19:41:10 +010033%{__make} REGEX="pcre" "COPTS.pcre=-DUSE_PCRE $(pcre-config --cflags)" DEBUG="" TARGET=linux24e
willy tarreaue4c2e102006-03-15 20:47:25 +010034#%{__make} REGEX=pcre DEBUG="" LIBS.pcre="-L\$(PCREDIR)/lib -Wl,-Bstatic -lpcreposix -lpcre -Wl,-Bdynamic"
35
willy tarreau982249e2005-12-18 00:57:06 +010036
37%install
willy tarreaue4c2e102006-03-15 20:47:25 +010038[ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
willy tarreau982249e2005-12-18 00:57:06 +010039
willy tarreaue4c2e102006-03-15 20:47:25 +010040%{__install} -d %{buildroot}%{_sbindir}
41%{__install} -d %{buildroot}%{_sysconfdir}/rc.d/init.d
42%{__install} -d %{buildroot}%{_sysconfdir}/%{name}
willy tarreau982249e2005-12-18 00:57:06 +010043
willy tarreaue4c2e102006-03-15 20:47:25 +010044%{__install} -s %{name} %{buildroot}%{_sbindir}/
45%{__install} -c -m 644 examples/%{name}.cfg %{buildroot}%{_sysconfdir}/%{name}/
46%{__install} -c -m 755 examples/%{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
willy tarreau982249e2005-12-18 00:57:06 +010047
48%clean
willy tarreaue4c2e102006-03-15 20:47:25 +010049[ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
willy tarreau982249e2005-12-18 00:57:06 +010050
51%post
willy tarreaue4c2e102006-03-15 20:47:25 +010052/sbin/chkconfig --add %{name}
willy tarreau982249e2005-12-18 00:57:06 +010053
54%preun
willy tarreaue4c2e102006-03-15 20:47:25 +010055if [ $1 = 0 ]; then
56 /sbin/service %{name} stop >/dev/null 2>&1 || :
57 /sbin/chkconfig --del %{name}
willy tarreau982249e2005-12-18 00:57:06 +010058fi
59
60%postun
willy tarreaue4c2e102006-03-15 20:47:25 +010061if [ "$1" -ge "1" ]; then
62 /sbin/service %{name} condrestart >/dev/null 2>&1 || :
willy tarreau982249e2005-12-18 00:57:06 +010063fi
64
65%files
willy tarreaue4c2e102006-03-15 20:47:25 +010066%defattr(-,root,root)
Willy Tarreau6bbf14c2006-07-09 09:08:05 +020067%doc CHANGELOG TODO examples doc/haproxy-en.txt doc/haproxy-fr.txt doc/architecture.txt examples/url-switching.cfg
willy tarreaue4c2e102006-03-15 20:47:25 +010068%attr(0755,root,root) %{_sbindir}/%{name}
69%dir %{_sysconfdir}/%{name}
70%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/%{name}.cfg
71%attr(0755,root,root) %config %{_sysconfdir}/rc.d/init.d/%{name}
willy tarreau982249e2005-12-18 00:57:06 +010072
73%changelog
Willy Tarreaue855f422007-10-18 22:38:22 +020074* Thu Oct 18 2007 Willy Tarreau <w@1wt.eu>
75- updated to 1.3.13
76
Willy Tarreaub21152b2007-06-17 23:41:40 +020077* Sun Jun 17 2007 Willy Tarreau <w@1wt.eu>
78- updated to 1.3.12
79
Willy Tarreaua3503e02007-06-03 17:27:07 +020080* Sun Jun 3 2007 Willy Tarreau <w@1wt.eu>
81- updated to 1.3.11.4
82
Willy Tarreau544eb402007-05-14 02:42:33 +020083* Mon May 14 2007 Willy Tarreau <w@1wt.eu>
Willy Tarreau3c6fc072007-05-14 14:40:25 +020084- updated to 1.3.11.3
85
86* Mon May 14 2007 Willy Tarreau <w@1wt.eu>
Willy Tarreaufc273c22007-05-14 03:42:47 +020087- updated to 1.3.11.2
88
89* Mon May 14 2007 Willy Tarreau <w@1wt.eu>
Willy Tarreau3c5340c2007-05-14 03:18:43 +020090- updated to 1.3.11.1
91
92* Mon May 14 2007 Willy Tarreau <w@1wt.eu>
Willy Tarreau544eb402007-05-14 02:42:33 +020093- updated to 1.3.11
94
Willy Tarreau9ca931f2007-05-10 07:51:17 +020095* Thu May 10 2007 Willy Tarreau <w@1wt.eu>
96- updated to 1.3.10.2
97
Willy Tarreau13398d32007-05-09 22:58:28 +020098* Tue May 09 2007 Willy Tarreau <w@1wt.eu>
99- updated to 1.3.10.1
100
Willy Tarreau61beedf2007-05-09 01:44:58 +0200101* Tue May 08 2007 Willy Tarreau <w@1wt.eu>
102- updated to 1.3.10
103
Willy Tarreau6e0433f2007-04-16 01:18:12 +0200104* Sun Apr 15 2007 Willy Tarreau <w@1wt.eu>
105- updated to 1.3.9
106
Willy Tarreau42c76592007-04-03 20:30:13 +0200107* Tue Apr 03 2007 Willy Tarreau <w@1wt.eu>
108- updated to 1.3.8.2
109
Willy Tarreauef6d7612007-04-01 11:06:22 +0200110* Sun Apr 01 2007 Willy Tarreau <w@1wt.eu>
111- updated to 1.3.8.1
112
Willy Tarreaud661cc02007-03-26 00:24:56 +0200113* Sun Mar 25 2007 Willy Tarreau <w@1wt.eu>
114- updated to 1.3.8
115
Willy Tarreau9cabf702007-01-26 23:49:01 +0100116* Wed Jan 26 2007 Willy Tarreau <w@1wt.eu>
117- updated to 1.3.7
118
Willy Tarreau49e1ee82007-01-22 00:56:46 +0100119* Wed Jan 22 2007 Willy Tarreau <w@1wt.eu>
120- updated to 1.3.6
121
Willy Tarreau5871f8e2007-01-07 02:47:01 +0100122* Wed Jan 07 2007 Willy Tarreau <w@1wt.eu>
123- updated to 1.3.5
124
Willy Tarreau85270da2007-01-02 00:59:39 +0100125* Wed Jan 02 2007 Willy Tarreau <w@1wt.eu>
126- updated to 1.3.4
127
Willy Tarreau9c9fea42006-10-16 00:03:35 +0200128* Wed Oct 15 2006 Willy Tarreau <w@1wt.eu>
129- updated to 1.3.3
130
Willy Tarreau690f9aa2006-09-03 11:23:06 +0200131* Wed Sep 03 2006 Willy Tarreau <w@1wt.eu>
132- updated to 1.3.2
133
Willy Tarreau8f2b8552006-07-09 17:11:39 +0200134* Wed Jul 09 2006 Willy Tarreau <w@1wt.eu>
135- updated to 1.3.1
136
willy tarreau7e6328d2006-05-21 23:26:20 +0200137* Wed May 21 2006 Willy Tarreau <willy@w.ods.org>
138- updated to 1.2.14
139
willy tarreauc3a2e072006-05-13 18:51:38 +0200140* Wed May 01 2006 Willy Tarreau <willy@w.ods.org>
141- updated to 1.2.13
142
willy tarreauc0d4bbd2006-04-15 21:47:50 +0200143* Wed Apr 15 2006 Willy Tarreau <willy@w.ods.org>
144- updated to 1.2.12
145
willy tarreaua60214e2006-03-30 18:03:39 +0200146* Wed Mar 30 2006 Willy Tarreau <willy@w.ods.org>
147- updated to 1.2.11.1
148
willy tarreaud8b1fa52006-03-19 21:01:07 +0100149* Wed Mar 19 2006 Willy Tarreau <willy@w.ods.org>
150- updated to 1.2.10
151
willy tarreaue4c2e102006-03-15 20:47:25 +0100152* Wed Mar 15 2006 Willy Tarreau <willy@w.ods.org>
153- updated to 1.2.9
154
155* Sat Jan 22 2005 Willy Tarreau <willy@w.ods.org>
156- updated to 1.2.3 (1.1.30)
157
158* Sun Nov 14 2004 Willy Tarreau <w@w.ods.org>
159- updated to 1.1.29
160- fixed path to config and init files
161- statically linked PCRE to increase portability to non-pcre systems
162
163* Sun Jun 6 2004 Willy Tarreau <willy@w.ods.org>
164- updated to 1.1.28
165- added config check support to the init script
166
167* Tue Oct 28 2003 Simon Matter <simon.matter@invoca.ch>
168- updated to 1.1.27
169- added pid support to the init script
170
171* Wed Oct 22 2003 Simon Matter <simon.matter@invoca.ch>
172- updated to 1.1.26
willy tarreau982249e2005-12-18 00:57:06 +0100173
willy tarreaue4c2e102006-03-15 20:47:25 +0100174* Thu Oct 16 2003 Simon Matter <simon.matter@invoca.ch>
175- initial build