blob: a9f4ed2767e31833ba764761b5c4c2aab28a2450 [file] [log] [blame]
willy tarreau982249e2005-12-18 00:57:06 +01001Summary: HA-Proxy is a TCP/HTTP reverse proxy for high availability environments
2Name: haproxy
willy tarreaua60214e2006-03-30 18:03:39 +02003Version: 1.2.11.1
willy tarreau982249e2005-12-18 00:57:06 +01004Release: 1
5License: GPL
6Group: System Environment/Daemons
willy tarreaue4c2e102006-03-15 20:47:25 +01007URL: http://w.ods.org/tools/%{name}/
8Source0: http://w.ods.org/tools/%{name}/%{name}-%{version}.tar.gz
9BuildRoot: %{_tmppath}/%{name}-%{version}-root
willy tarreau982249e2005-12-18 00:57:06 +010010BuildRequires: pcre-devel
willy tarreaub6da4792006-03-15 19:41:10 +010011Requires: /sbin/chkconfig, /sbin/service
willy tarreau982249e2005-12-18 00:57:06 +010012
13%description
14HA-Proxy is a TCP/HTTP reverse proxy which is particularly suited for high
15availability environments. Indeed, it can:
16- route HTTP requests depending on statically assigned cookies
17- spread the load among several servers while assuring server persistence
18 through the use of HTTP cookies
19- switch to backup servers in the event a main one fails
20- accept connections to special ports dedicated to service monitoring
21- stop accepting connections without breaking existing ones
22- add/modify/delete HTTP headers both ways
23- block requests matching a particular pattern
24
25It needs very little resource. Its event-driven architecture allows it to easily
26handle thousands of simultaneous connections on hundreds of instances without
27risking the system's stability.
28
29%prep
willy tarreaue4c2e102006-03-15 20:47:25 +010030%setup -q
willy tarreau982249e2005-12-18 00:57:06 +010031
32%build
willy tarreaub6da4792006-03-15 19:41:10 +010033%{__make} REGEX="pcre" "COPTS.pcre=-DUSE_PCRE $(pcre-config --cflags)" DEBUG="" TARGET=linux24e
willy tarreaue4c2e102006-03-15 20:47:25 +010034#%{__make} REGEX=pcre DEBUG="" LIBS.pcre="-L\$(PCREDIR)/lib -Wl,-Bstatic -lpcreposix -lpcre -Wl,-Bdynamic"
35
willy tarreau982249e2005-12-18 00:57:06 +010036
37%install
willy tarreaue4c2e102006-03-15 20:47:25 +010038[ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
willy tarreau982249e2005-12-18 00:57:06 +010039
willy tarreaue4c2e102006-03-15 20:47:25 +010040%{__install} -d %{buildroot}%{_sbindir}
41%{__install} -d %{buildroot}%{_sysconfdir}/rc.d/init.d
42%{__install} -d %{buildroot}%{_sysconfdir}/%{name}
willy tarreau982249e2005-12-18 00:57:06 +010043
willy tarreaue4c2e102006-03-15 20:47:25 +010044%{__install} -s %{name} %{buildroot}%{_sbindir}/
45%{__install} -c -m 644 examples/%{name}.cfg %{buildroot}%{_sysconfdir}/%{name}/
46%{__install} -c -m 755 examples/%{name}.init %{buildroot}%{_sysconfdir}/rc.d/init.d/%{name}
willy tarreau982249e2005-12-18 00:57:06 +010047
48%clean
willy tarreaue4c2e102006-03-15 20:47:25 +010049[ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
willy tarreau982249e2005-12-18 00:57:06 +010050
51%post
willy tarreaue4c2e102006-03-15 20:47:25 +010052/sbin/chkconfig --add %{name}
willy tarreau982249e2005-12-18 00:57:06 +010053
54%preun
willy tarreaue4c2e102006-03-15 20:47:25 +010055if [ $1 = 0 ]; then
56 /sbin/service %{name} stop >/dev/null 2>&1 || :
57 /sbin/chkconfig --del %{name}
willy tarreau982249e2005-12-18 00:57:06 +010058fi
59
60%postun
willy tarreaue4c2e102006-03-15 20:47:25 +010061if [ "$1" -ge "1" ]; then
62 /sbin/service %{name} condrestart >/dev/null 2>&1 || :
willy tarreau982249e2005-12-18 00:57:06 +010063fi
64
65%files
willy tarreaue4c2e102006-03-15 20:47:25 +010066%defattr(-,root,root)
67%doc CHANGELOG TODO examples doc/haproxy-en.txt doc/haproxy-fr.txt doc/architecture.txt
68%attr(0755,root,root) %{_sbindir}/%{name}
69%dir %{_sysconfdir}/%{name}
70%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/%{name}/%{name}.cfg
71%attr(0755,root,root) %config %{_sysconfdir}/rc.d/init.d/%{name}
willy tarreau982249e2005-12-18 00:57:06 +010072
73%changelog
willy tarreaua60214e2006-03-30 18:03:39 +020074* Wed Mar 30 2006 Willy Tarreau <willy@w.ods.org>
75- updated to 1.2.11.1
76
willy tarreaud8b1fa52006-03-19 21:01:07 +010077* Wed Mar 19 2006 Willy Tarreau <willy@w.ods.org>
78- updated to 1.2.10
79
willy tarreaue4c2e102006-03-15 20:47:25 +010080* Wed Mar 15 2006 Willy Tarreau <willy@w.ods.org>
81- updated to 1.2.9
82
83* Sat Jan 22 2005 Willy Tarreau <willy@w.ods.org>
84- updated to 1.2.3 (1.1.30)
85
86* Sun Nov 14 2004 Willy Tarreau <w@w.ods.org>
87- updated to 1.1.29
88- fixed path to config and init files
89- statically linked PCRE to increase portability to non-pcre systems
90
91* Sun Jun 6 2004 Willy Tarreau <willy@w.ods.org>
92- updated to 1.1.28
93- added config check support to the init script
94
95* Tue Oct 28 2003 Simon Matter <simon.matter@invoca.ch>
96- updated to 1.1.27
97- added pid support to the init script
98
99* Wed Oct 22 2003 Simon Matter <simon.matter@invoca.ch>
100- updated to 1.1.26
willy tarreau982249e2005-12-18 00:57:06 +0100101
willy tarreaue4c2e102006-03-15 20:47:25 +0100102* Thu Oct 16 2003 Simon Matter <simon.matter@invoca.ch>
103- initial build