developer | b9b4cd1 | 2022-10-11 13:18:59 +0800 | [diff] [blame] | 1 | DESCRIPTION = "testmode daemon for nl80211"
|
| 2 | SECTION = "applications"
|
| 3 | LICENSE = "GPLv2"
|
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
|
| 5 |
|
| 6 | DEPENDS += "libnl-tiny"
|
developer | 8bd3e5a | 2023-03-02 17:10:52 +0800 | [diff] [blame] | 7 | RDEPENDS_${PN} += "bash"
|
developer | b9b4cd1 | 2022-10-11 13:18:59 +0800 | [diff] [blame] | 8 | inherit pkgconfig cmake
|
| 9 |
|
| 10 | SRC_URI = " \
|
| 11 | file://COPYING;subdir=git/src \
|
| 12 | file://src;subdir=git \
|
| 13 | file://ated.sh;subdir=git \
|
| 14 | file://iwpriv.sh;subdir=git \
|
developer | 8bd3e5a | 2023-03-02 17:10:52 +0800 | [diff] [blame] | 15 | file://001-RDKB-ash-to-bash.patch;apply=no \
|
developer | b9b4cd1 | 2022-10-11 13:18:59 +0800 | [diff] [blame] | 16 | "
|
| 17 |
|
| 18 | S = "${WORKDIR}/git/src"
|
| 19 |
|
| 20 | CFLAGS_append = " -I=${includedir}/libnl-tiny "
|
| 21 |
|
developer | 8bd3e5a | 2023-03-02 17:10:52 +0800 | [diff] [blame] | 22 | do_mtk_patches() {
|
| 23 | cd ${S}/../
|
| 24 |
|
| 25 | if [ ! -e mtk_wifi_patch_applied ]; then
|
| 26 | patch -p1 < ${WORKDIR}/001-RDKB-ash-to-bash.patch
|
| 27 | fi
|
| 28 | touch mtk_wifi_patch_applied
|
| 29 | }
|
| 30 | addtask mtk_patches after do_patch before do_configure
|
developer | b9b4cd1 | 2022-10-11 13:18:59 +0800 | [diff] [blame] | 31 |
|
| 32 | do_install_append() {
|
| 33 | install -d ${D}${sbindir}
|
| 34 | install -m 0755 ${WORKDIR}/git/ated.sh ${D}${sbindir}/ated
|
| 35 | install -m 0755 ${WORKDIR}/git/iwpriv.sh ${D}${sbindir}/iwpriv
|
developer | 6941012 | 2023-01-13 16:28:41 +0800 | [diff] [blame] | 36 | install -m 0755 ${WORKDIR}/git/iwpriv.sh ${D}${sbindir}/mwctl
|
developer | b9b4cd1 | 2022-10-11 13:18:59 +0800 | [diff] [blame] | 37 | }
|
| 38 |
|