[rdkb][common][app][Add atenl tool for wifi test mode]

[Description]
Add atenl tool for wifi test mode
1. add atenl test mode tool
2. remove iwpriv from wireless tools, because of iwpriv command of wireless-tool is conflict with the iwpriv of atenl

[Release-log]

diff --git a/recipes-devtools/atenl/atenl.bb b/recipes-devtools/atenl/atenl.bb
new file mode 100644
index 0000000..ca5cb4e
--- /dev/null
+++ b/recipes-devtools/atenl/atenl.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "testmode daemon for nl80211"

+SECTION = "applications"

+LICENSE = "GPLv2"

+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"

+

+DEPENDS += "libnl-tiny"

+RDEPENDS_${PN} += "busybox"

+inherit pkgconfig cmake

+

+SRC_URI = " \

+    file://COPYING;subdir=git/src \

+    file://src;subdir=git \

+    file://ated.sh;subdir=git \

+    file://iwpriv.sh;subdir=git \

+    "

+

+S = "${WORKDIR}/git/src"

+

+CFLAGS_append = " -I=${includedir}/libnl-tiny "

+

+

+do_install_append() {

+    install -d ${D}${sbindir}

+    install -m 0755 ${WORKDIR}/git/ated.sh ${D}${sbindir}/ated

+    install -m 0755 ${WORKDIR}/git/iwpriv.sh ${D}${sbindir}/iwpriv

+}

+