blob: 2f768bd2e4f15cf6a31b323eacdec31cab6fca81 [file] [log] [blame]
developer9ac79da2022-10-31 14:57:29 +08001DESCRIPTION = "mt76-test"
2SECTION = "applications"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://../COPYING;md5=c188eeeb69c0a05d0545816f1458a0c9"
5
6DEPENDS += "libnl-tiny"
7
8inherit pkgconfig cmake
9
10PV = "1.0"
11
12require mt76.inc
13SRC_URI = " \
14 git://git@github.com/openwrt/mt76.git;protocol=https \
15 file://COPYING;subdir=git \
developerd4e2b9d2022-12-15 16:48:11 +080016 file://5000-mt76-add-internal-wed_tiny-header-file.patch;apply=no\
developer9ac79da2022-10-31 14:57:29 +080017 "
18
19
developerddae1502022-11-16 18:00:20 +080020
21
developer9ac79da2022-10-31 14:57:29 +080022DEPENDS += "virtual/kernel"
23DEPENDS += "linux-mac80211"
24DEPENDS += "linux-mt76"
25
26FILESEXTRAPATHS_prepend := "${THISDIR}/files/patches:"
27
28
29CFLAGS_append = " -I=${includedir}/libnl-tiny "
30
31S = "${WORKDIR}/git/tools"
32
33SRC_URI += "file://*.patch;apply=no"
34
developer9ac79da2022-10-31 14:57:29 +080035do_mtk_patches() {
36 cd ${S}/../
developerddae1502022-11-16 18:00:20 +080037
developer9ac79da2022-10-31 14:57:29 +080038 if [ ! -e mtk_wifi_patch_applied ]; then
developerd4e2b9d2022-12-15 16:48:11 +080039 for i in ${WORKDIR}/*.patch; do patch -p1 < $i; done
developer9ac79da2022-10-31 14:57:29 +080040 fi
41 touch mtk_wifi_patch_applied
42}
43addtask mtk_patches after do_patch before do_configure
44
45
46
47
48
49