[rdkb][common][app][Add mt76-test tool]

[Description]
Add mt76-test tool
1. support mt76-test tool for Chihuahua tool
2. replace SRCREV from linux-mt76.bb to mt76.inc, because of the source code of mt76-test tool is in the source code of mt76.

[Release-log]

Change-Id: Ic37e07c021a0608ad5c7c5a5ab1b36a945959d6d
diff --git a/recipes-connectivity/linux-mt76/mt76-test.bb b/recipes-connectivity/linux-mt76/mt76-test.bb
new file mode 100644
index 0000000..f831b9f
--- /dev/null
+++ b/recipes-connectivity/linux-mt76/mt76-test.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "mt76-test"
+SECTION = "applications"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://../COPYING;md5=c188eeeb69c0a05d0545816f1458a0c9"
+
+DEPENDS += "libnl-tiny"
+
+inherit pkgconfig cmake
+
+PV = "1.0"
+
+require mt76.inc
+SRC_URI = " \
+    git://git@github.com/openwrt/mt76.git;protocol=https \
+    file://COPYING;subdir=git \
+    "
+
+
+DEPENDS += "virtual/kernel"
+DEPENDS += "linux-mac80211"
+DEPENDS += "linux-mt76"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files/patches:"
+
+
+CFLAGS_append = " -I=${includedir}/libnl-tiny "
+
+S = "${WORKDIR}/git/tools"
+
+SRC_URI += "file://*.patch;apply=no"
+
+
+do_mtk_patches() {
+	cd ${S}/../
+	if [ ! -e mtk_wifi_patch_applied ]; then
+		for i in ${WORKDIR}/*.patch; do patch -p1 < $i; done
+	fi
+	touch mtk_wifi_patch_applied
+}
+addtask mtk_patches after do_patch before do_configure
+
+
+
+
+
+