blob: db836fccd08c28e1f2bb2da234f0671940b18270 [file] [log] [blame]
developer0447f742022-10-31 14:57:29 +08001DESCRIPTION = "mt76-test"
2SECTION = "applications"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://../COPYING;md5=c188eeeb69c0a05d0545816f1458a0c9"
5
6DEPENDS += "libnl-tiny"
7
8inherit pkgconfig cmake
9
10PV = "1.0"
11
12require mt76.inc
developer327aa322023-07-10 13:49:56 +080013
developer0447f742022-10-31 14:57:29 +080014SRC_URI = " \
15 git://git@github.com/openwrt/mt76.git;protocol=https \
16 file://COPYING;subdir=git \
developer5f4cfb12022-12-15 16:48:11 +080017 file://5000-mt76-add-internal-wed_tiny-header-file.patch;apply=no\
developer0447f742022-10-31 14:57:29 +080018 "
19
20
developere6cee7d2022-11-16 18:00:20 +080021
22
developer0447f742022-10-31 14:57:29 +080023DEPENDS += "virtual/kernel"
24DEPENDS += "linux-mac80211"
25DEPENDS += "linux-mt76"
26
developer7af0f762023-05-22 15:16:16 +080027FILESEXTRAPATHS_prepend := "${@bb.utils.contains('DISTRO_FEATURES','wifi_eht','${THISDIR}/files/patches-3.x:','${THISDIR}/files/patches:',d)}"
developer0447f742022-10-31 14:57:29 +080028
29
30CFLAGS_append = " -I=${includedir}/libnl-tiny "
31
32S = "${WORKDIR}/git/tools"
33
34SRC_URI += "file://*.patch;apply=no"
35
developer0447f742022-10-31 14:57:29 +080036do_mtk_patches() {
37 cd ${S}/../
developere6cee7d2022-11-16 18:00:20 +080038
developer0447f742022-10-31 14:57:29 +080039 if [ ! -e mtk_wifi_patch_applied ]; then
developer5f4cfb12022-12-15 16:48:11 +080040 for i in ${WORKDIR}/*.patch; do patch -p1 < $i; done
developer0447f742022-10-31 14:57:29 +080041 fi
42 touch mtk_wifi_patch_applied
43}
44addtask mtk_patches after do_patch before do_configure
45
46
47
48
49
50