[rdkb][common][bsp][Refactor mt76-add-internal-wed_tiny-header-file.patch]
[Description]
Refactor mt76-add-internal-wed_tiny-header-file.patch
1. when disable flow_offload feature, only kernel and mac80211 will not patch related patches of wed.
2. mt76 will patch all the patches include related patches of wed and this patch "5000-mt76-add-internal-wed_tiny-header-file.patch"
in flow_offload feature enable and disable situation.
[Release-log]
diff --git a/recipes-wifi/linux-mt76/mt76-test.bb b/recipes-wifi/linux-mt76/mt76-test.bb
index 6af254f..2f768bd 100644
--- a/recipes-wifi/linux-mt76/mt76-test.bb
+++ b/recipes-wifi/linux-mt76/mt76-test.bb
@@ -13,7 +13,7 @@
SRC_URI = " \
git://git@github.com/openwrt/mt76.git;protocol=https \
file://COPYING;subdir=git \
- file://0001-mt76-add-internal-wed_tiny-header-file.patch;apply=no \
+ file://5000-mt76-add-internal-wed_tiny-header-file.patch;apply=no\
"
@@ -34,26 +34,9 @@
do_mtk_patches() {
cd ${S}/../
- DISTRO_FlowBlock_ENABLED="${@bb.utils.contains('DISTRO_FEATURES','flow_offload','true','false',d)}"
if [ ! -e mtk_wifi_patch_applied ]; then
- for i in ${WORKDIR}/*.patch
- do
- if [ $DISTRO_FlowBlock_ENABLED = 'true' ]; then
- patch -p1 < $i;
- else
- prefix=$(echo -n "${WORKDIR}"|wc -c)
- patch_number_start=$(expr $prefix + 2)
- patch_number_end=$(expr $patch_number_start + 3 )
- patch_number=$(echo "$i" | cut -c"$patch_number_start"-"$patch_number_end")
-
- if [ "$patch_number" -ge "3000" ]; then
- continue;
- else
- patch -p1 < $i;
- fi
- fi
- done
+ for i in ${WORKDIR}/*.patch; do patch -p1 < $i; done
fi
touch mtk_wifi_patch_applied
}