developer | 21ea813 | 2022-07-11 11:52:59 +0800 | [diff] [blame] | 1 | SUMMARY = "Command to config switch" |
| 2 | SECTION = "applications" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 5 | |
developer | 21ea813 | 2022-07-11 11:52:59 +0800 | [diff] [blame] | 6 | |
| 7 | DEPENDS = "libnl" |
| 8 | |
| 9 | SRC_URI = " \ |
developer | d23a4c1 | 2022-11-03 11:33:07 +0800 | [diff] [blame] | 10 | file://COPYING;subdir=git/src \ |
| 11 | file://src;subdir=git \ |
| 12 | file://rdkb-change-bridge-name.patch \ |
developer | 21ea813 | 2022-07-11 11:52:59 +0800 | [diff] [blame] | 13 | " |
| 14 | |
developer | d23a4c1 | 2022-11-03 11:33:07 +0800 | [diff] [blame] | 15 | S = "${WORKDIR}/git/src" |
| 16 | |
developer | 21ea813 | 2022-07-11 11:52:59 +0800 | [diff] [blame] | 17 | CFLAGS_prepend = " \ |
| 18 | -D_GNU_SOURCE \ |
| 19 | -I${STAGING_INCDIR}/libnl3 \ |
| 20 | -I${S} \ |
| 21 | " |
| 22 | |
| 23 | do_compile() { |
| 24 | oe_runmake -C ${S} "LIBS=-L${STAGING_LIBDIR} -lnl-3 -lnl-genl-3 -lm" |
| 25 | } |
| 26 | |
| 27 | do_install() { |
| 28 | install -d ${D}/usr/sbin |
| 29 | install -d ${D}/lib/network |
developer | d23a4c1 | 2022-11-03 11:33:07 +0800 | [diff] [blame] | 30 | install -m 0755 ${S}/switch ${D}/usr/sbin |
developer | 21ea813 | 2022-07-11 11:52:59 +0800 | [diff] [blame] | 31 | } |