[rdkb][common][app][Refactor switch tool]

[Description]
Refactor switch tool
1. align to newest openwrt version
2. add a patch to change the differences between openwrt and RDKB such as bridge name ...

[Release-log]

Change-Id: Iaba64709f3be51a2764b5374c043aa793596721d
diff --git a/recipes-devtools/switch/switch_1.0.bb b/recipes-devtools/switch/switch_1.0.bb
index 5c95e6e..133b669 100644
--- a/recipes-devtools/switch/switch_1.0.bb
+++ b/recipes-devtools/switch/switch_1.0.bb
@@ -3,23 +3,17 @@
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
 
-S = "${WORKDIR}"
 
 DEPENDS = "libnl"
 
 SRC_URI = " \
-    file://COPYING \
-    file://Makefile \
-    file://switch_753x.c \
-    file://switch_extend.h \
-    file://switch_fun.c \
-    file://switch_fun.h \
-    file://switch_ioctl.c \
-    file://switch_ioctl.h \
-    file://switch_netlink.c \
-    file://switch_netlink.h \
+    file://COPYING;subdir=git/src \
+    file://src;subdir=git \
+    file://rdkb-change-bridge-name.patch \
     "
 
+S = "${WORKDIR}/git/src"
+
 CFLAGS_prepend = " \
     -D_GNU_SOURCE \
     -I${STAGING_INCDIR}/libnl3 \
@@ -33,5 +27,5 @@
 do_install() {
     install -d ${D}/usr/sbin
     install -d ${D}/lib/network
-    install -m 0755 ${WORKDIR}/switch ${D}/usr/sbin
+    install -m 0755 ${S}/switch ${D}/usr/sbin
 }