blob: 133b669c2a917194c0d602ee272e2b81a65c88f9 [file] [log] [blame]
developer21ea8132022-07-11 11:52:59 +08001SUMMARY = "Command to config switch"
2SECTION = "applications"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5
developer21ea8132022-07-11 11:52:59 +08006
7DEPENDS = "libnl"
8
9SRC_URI = " \
developerd23a4c12022-11-03 11:33:07 +080010 file://COPYING;subdir=git/src \
11 file://src;subdir=git \
12 file://rdkb-change-bridge-name.patch \
developer21ea8132022-07-11 11:52:59 +080013 "
14
developerd23a4c12022-11-03 11:33:07 +080015S = "${WORKDIR}/git/src"
16
developer21ea8132022-07-11 11:52:59 +080017CFLAGS_prepend = " \
18 -D_GNU_SOURCE \
19 -I${STAGING_INCDIR}/libnl3 \
20 -I${S} \
21 "
22
23do_compile() {
24 oe_runmake -C ${S} "LIBS=-L${STAGING_LIBDIR} -lnl-3 -lnl-genl-3 -lm"
25}
26
27do_install() {
28 install -d ${D}/usr/sbin
29 install -d ${D}/lib/network
developerd23a4c12022-11-03 11:33:07 +080030 install -m 0755 ${S}/switch ${D}/usr/sbin
developer21ea8132022-07-11 11:52:59 +080031}