blob: c4682011f77fb8f66041907d28c2637ecef9f4bd [file] [log] [blame]
developerc7ea0b72022-08-22 16:58:20 +08001SUMMARY = "Init filogic "
2SECTION = "applications"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5
6S = "${WORKDIR}"
7inherit systemd
8
9SRC_URI = " \
10 file://COPYING \
11 file://MACSec.sh \
12 file://MACSec.service \
13 "
14
15SYSTEMD_PACKAGES = "${PN}"
16SYSTEMD_AUTO_ENABLE_${PN} = "disable"
17SYSTEMD_SERVICE_${PN} = " MACSec.service"
18FILES_${PN} += "{systemd_unitdir}/system/MACSec.service"
19
20do_install() {
21 install -d ${D}${sbindir}
22 install -m 0755 ${WORKDIR}/MACSec.sh ${D}${sbindir}
23 install -d ${D}${systemd_unitdir}/system/
24 install -m 0644 ${S}/MACSec.service ${D}${systemd_unitdir}/system
25}