[rdkb][common][app][Add MACsec service for platform HAL]

[Description]
Add MACsec service for platform HAL

[Release-log]

diff --git a/recipes-devtools/mac-sec/mac-sec.bb b/recipes-devtools/mac-sec/mac-sec.bb
new file mode 100644
index 0000000..c468201
--- /dev/null
+++ b/recipes-devtools/mac-sec/mac-sec.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Init filogic "
+SECTION = "applications"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+S = "${WORKDIR}"
+inherit systemd
+
+SRC_URI = " \
+    file://COPYING \
+    file://MACSec.sh \
+    file://MACSec.service \
+    "
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_AUTO_ENABLE_${PN} = "disable"
+SYSTEMD_SERVICE_${PN} = " MACSec.service"
+FILES_${PN} += "{systemd_unitdir}/system/MACSec.service"
+
+do_install() {
+    install -d ${D}${sbindir}
+    install -m 0755 ${WORKDIR}/MACSec.sh ${D}${sbindir}
+    install -d ${D}${systemd_unitdir}/system/
+    install -m 0644 ${S}/MACSec.service ${D}${systemd_unitdir}/system
+}