developer | 0fa096b | 2022-04-12 19:48:09 +0800 | [diff] [blame] | 1 | SUMMARY = "nl80211 based CLI configuration utility for wireless devices" |
| 2 | DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \ |
| 3 | wireless devices. It supports almost all new drivers that have been added \ |
| 4 | to the kernel recently. " |
| 5 | HOMEPAGE = "https://wireless.wiki.kernel.org/en/users/documentation/iw" |
| 6 | SECTION = "base" |
| 7 | LICENSE = "BSD-2-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774" |
| 9 | |
| 10 | DEPENDS = "libnl" |
| 11 | |
developer | 6caa5e2 | 2022-06-16 13:33:13 +0800 | [diff] [blame] | 12 | SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.xz \ |
developer | 0fa096b | 2022-04-12 19:48:09 +0800 | [diff] [blame] | 13 | file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \ |
| 14 | file://separate-objdir.patch \ |
| 15 | " |
| 16 | |
developer | 42c7a43 | 2024-07-12 14:39:29 +0800 | [diff] [blame^] | 17 | SRC_URI[sha256sum] = "3f2db22ad41c675242b98ae3942dbf3112548c60a42ff739210f2de4e98e4894" |
developer | 6b200c7 | 2022-06-15 19:48:25 +0800 | [diff] [blame] | 18 | |
developer | 66e89bc | 2024-04-23 14:50:01 +0800 | [diff] [blame] | 19 | PATCH_SRC = "${@bb.utils.contains('DISTRO_FEATURES', 'wifi_eht', 'patches-mlo', 'patches', d)}" |
| 20 | |
| 21 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PATCH_SRC}:" |
| 22 | require ${PATCH_SRC}/patches.inc |
developer | 0fa096b | 2022-04-12 19:48:09 +0800 | [diff] [blame] | 23 | |
developer | 4d58186 | 2023-02-13 16:01:56 +0800 | [diff] [blame] | 24 | SRC_URI_remove = "${@bb.utils.contains('DISTRO_FEATURES', 'wifi_eht', 'file://001-nl80211_h_sync.patch', '', d)}" |
| 25 | SRC_URI_remove = "${@bb.utils.contains('DISTRO_FEATURES', 'wifi_eht', 'file://120-antenna_gain.patch', '', d)}" |
| 26 | |
developer | 0fa096b | 2022-04-12 19:48:09 +0800 | [diff] [blame] | 27 | inherit pkgconfig |
| 28 | |
developer | 4d58186 | 2023-02-13 16:01:56 +0800 | [diff] [blame] | 29 | |
developer | 0fa096b | 2022-04-12 19:48:09 +0800 | [diff] [blame] | 30 | EXTRA_OEMAKE = "\ |
| 31 | -f '${S}/Makefile' \ |
| 32 | \ |
| 33 | 'PREFIX=${prefix}' \ |
| 34 | 'SBINDIR=${sbindir}' \ |
| 35 | 'MANDIR=${mandir}' \ |
| 36 | " |
| 37 | |
| 38 | do_install() { |
| 39 | oe_runmake 'DESTDIR=${D}' install |
| 40 | } |