blob: fb95959eb45ebf085cc2555c88ff95a6d0809328 [file] [log] [blame]
developer0fa096b2022-04-12 19:48:09 +08001SUMMARY = "nl80211 based CLI configuration utility for wireless devices"
2DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \
3wireless devices. It supports almost all new drivers that have been added \
4to the kernel recently. "
5HOMEPAGE = "https://wireless.wiki.kernel.org/en/users/documentation/iw"
6SECTION = "base"
7LICENSE = "BSD-2-Clause"
8LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
9
10DEPENDS = "libnl"
11
developer6caa5e22022-06-16 13:33:13 +080012SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.xz \
developer0fa096b2022-04-12 19:48:09 +080013 file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \
14 file://separate-objdir.patch \
15"
16
developer42c7a432024-07-12 14:39:29 +080017SRC_URI[sha256sum] = "3f2db22ad41c675242b98ae3942dbf3112548c60a42ff739210f2de4e98e4894"
developer6b200c72022-06-15 19:48:25 +080018
developer66e89bc2024-04-23 14:50:01 +080019PATCH_SRC = "${@bb.utils.contains('DISTRO_FEATURES', 'wifi_eht', 'patches-mlo', 'patches', d)}"
20
21FILESEXTRAPATHS_prepend := "${THISDIR}/${PATCH_SRC}:"
22require ${PATCH_SRC}/patches.inc
developer0fa096b2022-04-12 19:48:09 +080023
developer4d581862023-02-13 16:01:56 +080024SRC_URI_remove = "${@bb.utils.contains('DISTRO_FEATURES', 'wifi_eht', 'file://001-nl80211_h_sync.patch', '', d)}"
25SRC_URI_remove = "${@bb.utils.contains('DISTRO_FEATURES', 'wifi_eht', 'file://120-antenna_gain.patch', '', d)}"
26
developer0fa096b2022-04-12 19:48:09 +080027inherit pkgconfig
28
developer4d581862023-02-13 16:01:56 +080029
developer0fa096b2022-04-12 19:48:09 +080030EXTRA_OEMAKE = "\
31 -f '${S}/Makefile' \
32 \
33 'PREFIX=${prefix}' \
34 'SBINDIR=${sbindir}' \
35 'MANDIR=${mandir}' \
36"
37
38do_install() {
39 oe_runmake 'DESTDIR=${D}' install
40}