[rdkb][common][bsp][Refactor and sync wifi from openwrt]

[Description]
d5ae826 [MAC80211][mt76][Fix AP crash when a station connects to AP]
5ba8783 [MAC80211][misc][Add MT7996 external openwrt build]
9e48559 [MAC80211][mt76][move muru_onoff in mt7915_phy]
1477805 [mac80211][mt76][wifi: mt76: update tx statistics]

[Release-log]

Change-Id: I93284df17ea450cba0339fa97e46dd00c40f4d9b
diff --git a/recipes-wifi/iw/iw_5.19.bb b/recipes-wifi/iw/iw_5.19.bb
index 8241477..861bf50 100644
--- a/recipes-wifi/iw/iw_5.19.bb
+++ b/recipes-wifi/iw/iw_5.19.bb
@@ -19,8 +19,12 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/patches:"
 require patches/patches.inc
 
+SRC_URI_remove = "${@bb.utils.contains('DISTRO_FEATURES', 'wifi_eht', 'file://001-nl80211_h_sync.patch', '', d)}"
+SRC_URI_remove = "${@bb.utils.contains('DISTRO_FEATURES', 'wifi_eht', 'file://120-antenna_gain.patch', '', d)}"
+
 inherit pkgconfig
 
+
 EXTRA_OEMAKE = "\
     -f '${S}/Makefile' \
     \