developer | eca9e8f | 2022-10-24 11:36:03 +0800 | [diff] [blame] | 1 | DESCRIPTION = "Hardware-QoS-tool" |
| 2 | SECTION = "applications" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 5 | |
| 6 | DEPENDS += "libnl-tiny uci" |
| 7 | |
| 8 | inherit autotools coverity |
| 9 | |
| 10 | SRC_URI = " \ |
| 11 | file://COPYING;subdir=git/src \ |
| 12 | file://src;subdir=git \ |
| 13 | " |
| 14 | |
| 15 | S = "${WORKDIR}/git/src" |
| 16 | |
| 17 | CFLAGS_append = " -luci " |
| 18 | |
| 19 | do_install_append() { |
| 20 | install -d ${D}${sysconfdir} |
| 21 | install -d ${D}${sysconfdir}/config |
| 22 | install -m 0755 ${WORKDIR}/git/src/mtkhnat.config ${D}${sysconfdir}/config/mtkhnat |
| 23 | } |