[rdkb][common][app][Add HQoS tool]
[Description]
Add HQoS tool
1. add mtkhnat-util tool to set HW QoS setting
2. add default config into /etc/config/mtkhnat
[Release-log]
diff --git a/recipes-devtools/mtkhnat-util/mtkhnat-util.bb b/recipes-devtools/mtkhnat-util/mtkhnat-util.bb
new file mode 100644
index 0000000..c5fe40f
--- /dev/null
+++ b/recipes-devtools/mtkhnat-util/mtkhnat-util.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Hardware-QoS-tool"
+SECTION = "applications"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+DEPENDS += "libnl-tiny uci"
+
+inherit autotools coverity
+
+SRC_URI = " \
+ file://COPYING;subdir=git/src \
+ file://src;subdir=git \
+ "
+
+S = "${WORKDIR}/git/src"
+
+CFLAGS_append = " -luci "
+
+do_install_append() {
+ install -d ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/config
+ install -m 0755 ${WORKDIR}/git/src/mtkhnat.config ${D}${sysconfdir}/config/mtkhnat
+}