developer | 0fa096b | 2022-04-12 19:48:09 +0800 | [diff] [blame] | 1 | SUMMARY = "nl80211 based CLI configuration utility for wireless devices" |
| 2 | DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \ |
| 3 | wireless devices. It supports almost all new drivers that have been added \ |
| 4 | to the kernel recently. " |
| 5 | HOMEPAGE = "https://wireless.wiki.kernel.org/en/users/documentation/iw" |
| 6 | SECTION = "base" |
| 7 | LICENSE = "BSD-2-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774" |
| 9 | |
| 10 | DEPENDS = "libnl" |
| 11 | |
developer | 6caa5e2 | 2022-06-16 13:33:13 +0800 | [diff] [blame] | 12 | SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.xz \ |
developer | 0fa096b | 2022-04-12 19:48:09 +0800 | [diff] [blame] | 13 | file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \ |
| 14 | file://separate-objdir.patch \ |
| 15 | " |
| 16 | |
developer | 6caa5e2 | 2022-06-16 13:33:13 +0800 | [diff] [blame] | 17 | SRC_URI[sha256sum] = "f167bbe947dd53bb9ebc0c1dcef5db6ad73ac1d6084f2c6f9376c5c360cc4d4e" |
developer | 6b200c7 | 2022-06-15 19:48:25 +0800 | [diff] [blame] | 18 | |
| 19 | FILESEXTRAPATHS_prepend := "${THISDIR}/patches:" |
| 20 | require patches/patches.inc |
developer | 0fa096b | 2022-04-12 19:48:09 +0800 | [diff] [blame] | 21 | |
developer | 4d58186 | 2023-02-13 16:01:56 +0800 | [diff] [blame] | 22 | SRC_URI_remove = "${@bb.utils.contains('DISTRO_FEATURES', 'wifi_eht', 'file://001-nl80211_h_sync.patch', '', d)}" |
| 23 | SRC_URI_remove = "${@bb.utils.contains('DISTRO_FEATURES', 'wifi_eht', 'file://120-antenna_gain.patch', '', d)}" |
| 24 | |
developer | 0fa096b | 2022-04-12 19:48:09 +0800 | [diff] [blame] | 25 | inherit pkgconfig |
| 26 | |
developer | 4d58186 | 2023-02-13 16:01:56 +0800 | [diff] [blame] | 27 | |
developer | 0fa096b | 2022-04-12 19:48:09 +0800 | [diff] [blame] | 28 | EXTRA_OEMAKE = "\ |
| 29 | -f '${S}/Makefile' \ |
| 30 | \ |
| 31 | 'PREFIX=${prefix}' \ |
| 32 | 'SBINDIR=${sbindir}' \ |
| 33 | 'MANDIR=${mandir}' \ |
| 34 | " |
| 35 | |
| 36 | do_install() { |
| 37 | oe_runmake 'DESTDIR=${D}' install |
| 38 | } |