blob: 861bf5079e759384b3ef324dad1861c9832debb0 [file] [log] [blame]
developer0fa096b2022-04-12 19:48:09 +08001SUMMARY = "nl80211 based CLI configuration utility for wireless devices"
2DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \
3wireless devices. It supports almost all new drivers that have been added \
4to the kernel recently. "
5HOMEPAGE = "https://wireless.wiki.kernel.org/en/users/documentation/iw"
6SECTION = "base"
7LICENSE = "BSD-2-Clause"
8LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
9
10DEPENDS = "libnl"
11
developer6caa5e22022-06-16 13:33:13 +080012SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.xz \
developer0fa096b2022-04-12 19:48:09 +080013 file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \
14 file://separate-objdir.patch \
15"
16
developer6caa5e22022-06-16 13:33:13 +080017SRC_URI[sha256sum] = "f167bbe947dd53bb9ebc0c1dcef5db6ad73ac1d6084f2c6f9376c5c360cc4d4e"
developer6b200c72022-06-15 19:48:25 +080018
19FILESEXTRAPATHS_prepend := "${THISDIR}/patches:"
20require patches/patches.inc
developer0fa096b2022-04-12 19:48:09 +080021
developer4d581862023-02-13 16:01:56 +080022SRC_URI_remove = "${@bb.utils.contains('DISTRO_FEATURES', 'wifi_eht', 'file://001-nl80211_h_sync.patch', '', d)}"
23SRC_URI_remove = "${@bb.utils.contains('DISTRO_FEATURES', 'wifi_eht', 'file://120-antenna_gain.patch', '', d)}"
24
developer0fa096b2022-04-12 19:48:09 +080025inherit pkgconfig
26
developer4d581862023-02-13 16:01:56 +080027
developer0fa096b2022-04-12 19:48:09 +080028EXTRA_OEMAKE = "\
29 -f '${S}/Makefile' \
30 \
31 'PREFIX=${prefix}' \
32 'SBINDIR=${sbindir}' \
33 'MANDIR=${mandir}' \
34"
35
36do_install() {
37 oe_runmake 'DESTDIR=${D}' install
38}