blob: f831b9fc53cf1eb5a1d96dfcfd8dbeb8f97cdf42 [file] [log] [blame]
developer9ac79da2022-10-31 14:57:29 +08001DESCRIPTION = "mt76-test"
2SECTION = "applications"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://../COPYING;md5=c188eeeb69c0a05d0545816f1458a0c9"
5
6DEPENDS += "libnl-tiny"
7
8inherit pkgconfig cmake
9
10PV = "1.0"
11
12require mt76.inc
13SRC_URI = " \
14 git://git@github.com/openwrt/mt76.git;protocol=https \
15 file://COPYING;subdir=git \
16 "
17
18
19DEPENDS += "virtual/kernel"
20DEPENDS += "linux-mac80211"
21DEPENDS += "linux-mt76"
22
23FILESEXTRAPATHS_prepend := "${THISDIR}/files/patches:"
24
25
26CFLAGS_append = " -I=${includedir}/libnl-tiny "
27
28S = "${WORKDIR}/git/tools"
29
30SRC_URI += "file://*.patch;apply=no"
31
32
33do_mtk_patches() {
34 cd ${S}/../
35 if [ ! -e mtk_wifi_patch_applied ]; then
36 for i in ${WORKDIR}/*.patch; do patch -p1 < $i; done
37 fi
38 touch mtk_wifi_patch_applied
39}
40addtask mtk_patches after do_patch before do_configure
41
42
43
44
45
46