blob: 0781f60dfefdb1b526d2899dc24b385ce36e6688 [file] [log] [blame]
developer15a43312022-04-12 11:23:23 +08001inherit rdk-image
2
3IMAGE_FEATURES_remove = "read-only-rootfs"
4
5SYSTEMD_TOOLS = "systemd-analyze systemd-bootchart"
6# systemd-bootchart doesn't currently build with musl libc
7SYSTEMD_TOOLS_remove_libc-musl = "systemd-bootchart"
8
9IMAGE_INSTALL += " packagegroup-turris-core \
10 ${SYSTEMD_TOOLS} \
11 linux-mac80211 \
12 kernel-module-compat \
13 kernel-module-cfg80211 \
14 kernel-module-mac80211 \
15 linux-mt76 \
16 kernel-module-mt76 \
17 kernel-module-mt7915e \
developere3b31392022-04-15 16:18:43 +080018 regs \
19 mii-mgr \
developer15a43312022-04-12 11:23:23 +080020 network-hotplug \
21 libmcrypt \
22 bzip2 \
23 libpcap \
24 tcpdump \
25 ebtables \
26 iw \
27 ethtool \
28 bc \
29 mesh-agent \
30 openvswitch \
31 opensync \
32 "
33
34BB_HASH_IGNORE_MISMATCH = "1"
35IMAGE_NAME[vardepsexclude] = "DATETIME"
36
37#ESDK-CHANGES
38do_populate_sdk_ext_prepend() {
39 builddir = d.getVar('TOPDIR')
40 if os.path.exists(builddir + '/conf/templateconf.cfg'):
41 with open(builddir + '/conf/templateconf.cfg', 'w') as f:
42 f.write('meta/conf\n')
43}
44
45sdk_ext_postinst_append() {
46 echo "ln -s $target_sdk_dir/layers/openembedded-core/meta-rdk $target_sdk_dir/layers/openembedded-core/../meta-rdk \n" >> $env_setup_script
47}
48
49PRSERV_HOST = "localhost:0"
50INHERIT += "buildhistory"
51BUILDHISTORY_COMMIT = "1"
52
53
54
55require image-exclude-files.inc
56
57remove_unused_file() {
58 for i in ${REMOVED_FILE_LIST} ; do rm -rf ${IMAGE_ROOTFS}/$i ; done
59}
60
61ROOTFS_POSTPROCESS_COMMAND_append = "remove_unused_file; "