developer | 15a4331 | 2022-04-12 11:23:23 +0800 | [diff] [blame] | 1 | EXTRA_OECONF_append = " --enable-ert --enable-platform" |
| 2 | |
| 3 | SRC_URI += "${CMF_GIT_ROOT}/rdkb/devices/turris/tdkb;protocol=${CMF_GIT_PROTOCOL};branch=${CMF_GIT_BRANCH};destsuffix=git/platform/turris;name=tdkbturris" |
| 4 | |
| 5 | SRCREV_tdkturris = "${AUTOREV}" |
| 6 | do_fetch[vardeps] += "SRCREV_tdkbturris" |
| 7 | SRCREV_FORMAT = "tdk_tdkbturris" |
| 8 | |
developer | 84bc359 | 2022-10-31 15:53:09 +0800 | [diff] [blame^] | 9 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" |
developer | fb68818 | 2022-06-08 14:48:19 +0800 | [diff] [blame] | 10 | |
developer | 84bc359 | 2022-10-31 15:53:09 +0800 | [diff] [blame^] | 11 | SRC_URI += "file://*.patch;apply=no \ |
| 12 | file://Set_properties.sh;subdir=git \ |
| 13 | " |
developer | fb68818 | 2022-06-08 14:48:19 +0800 | [diff] [blame] | 14 | |
| 15 | do_mtk_patches() { |
| 16 | cd ${S} |
| 17 | if [ ! -e mtk_wifi_patch_applied ]; then |
| 18 | for i in ${WORKDIR}/*.patch; do patch -p1 < $i; done |
| 19 | fi |
| 20 | touch mtk_wifi_patch_applied |
| 21 | } |
| 22 | addtask mtk_patches after do_unpack before do_compile |
| 23 | |
developer | 15a4331 | 2022-04-12 11:23:23 +0800 | [diff] [blame] | 24 | do_install_append () { |
| 25 | install -d ${D}${tdkdir} |
| 26 | install -d ${D}/etc |
| 27 | install -p -m 755 ${S}/platform/turris/agent/scripts/*.sh ${D}${tdkdir} |
| 28 | install -p -m 755 ${S}/platform/turris/agent/scripts/tdk_platform.properties ${D}/etc/ |
developer | 84bc359 | 2022-10-31 15:53:09 +0800 | [diff] [blame^] | 29 | install -p -m 755 ${S}/Set_properties.sh ${D}${tdkdir} |
developer | 15a4331 | 2022-04-12 11:23:23 +0800 | [diff] [blame] | 30 | } |
| 31 | |
| 32 | FILES_${PN} += "${prefix}/ccsp/" |
| 33 | FILES_${PN} += "/etc/*" |
| 34 | FILES_${PN} += "${tdkdir}/*" |
| 35 | |