developer | cc441a0 | 2022-05-09 19:04:26 +0800 | [diff] [blame] | 1 | require ccsp_common_filogic.inc |
developer | 4e8310e | 2024-02-23 14:25:14 +0800 | [diff] [blame] | 2 | FILESEXTRAPATHS_append := "${THISDIR}/files:" |
developer | cc441a0 | 2022-05-09 19:04:26 +0800 | [diff] [blame] | 3 | |
| 4 | DEPENDS_append_dunfell = " safec" |
| 5 | LDFLAGS_append_dunfell = " -lsafec-3.5.1" |
| 6 | |
| 7 | EXTRA_OECONF_remove = " ${@bb.utils.contains('DISTRO_FEATURES', 'rdkb_wan_manager', '--enable-wanmgr', '', d)}" |
| 8 | |
developer | 4e8310e | 2024-02-23 14:25:14 +0800 | [diff] [blame] | 9 | SRC_URI_append += " \ |
| 10 | file://Fix-ccsp-cm-agent-build-error.patch;apply=no \ |
| 11 | " |
| 12 | |
| 13 | do_filogic_patches() { |
| 14 | cd ${S} |
| 15 | |
| 16 | if ${@bb.utils.contains( 'DISTRO_FEATURES', '2022q3_support', 'true', 'false', d)}; then |
| 17 | patch -p1 < ${WORKDIR}/Fix-ccsp-cm-agent-build-error.patch |
| 18 | touch filogic_patch_applied |
| 19 | fi |
| 20 | } |
| 21 | addtask filogic_patches after do_unpack before do_configure |
| 22 | |
developer | cc441a0 | 2022-05-09 19:04:26 +0800 | [diff] [blame] | 23 | do_install_append() { |
| 24 | # Config files and scripts |
| 25 | install -m 644 ${S}/config-arm/CcspCMDM.cfg ${D}${prefix}/ccsp/cm/CcspCMDM.cfg |
| 26 | install -m 644 ${S}/config-arm/CcspCM.cfg ${D}${prefix}/ccsp/cm/CcspCM.cfg |
| 27 | install -m 644 ${S}/config-arm/TR181-CM.XML ${D}${prefix}/ccsp/cm/TR181-CM.XML |
| 28 | |
| 29 | # delete files that are installed by some other package |
| 30 | rm -f ${D}/usr/include/ccsp/cosa_apis.h |
| 31 | rm -f ${D}/usr/include/ccsp/cosa_apis_busutil.h |
| 32 | rm -f ${D}/usr/include/ccsp/cosa_dml_api_common.h |
| 33 | } |