blob: fb4e5b9051ea688a1b994cd1502d2b133fa9a072 [file] [log] [blame]
developer15a43312022-04-12 11:23:23 +08001inherit rdk-image
2
3IMAGE_FEATURES_remove = "read-only-rootfs"
4
5SYSTEMD_TOOLS = "systemd-analyze systemd-bootchart"
6# systemd-bootchart doesn't currently build with musl libc
7SYSTEMD_TOOLS_remove_libc-musl = "systemd-bootchart"
8
9IMAGE_INSTALL += " packagegroup-turris-core \
10 ${SYSTEMD_TOOLS} \
11 linux-mac80211 \
12 kernel-module-compat \
13 kernel-module-cfg80211 \
14 kernel-module-mac80211 \
15 linux-mt76 \
16 kernel-module-mt76 \
17 kernel-module-mt7915e \
developer15a43312022-04-12 11:23:23 +080018 network-hotplug \
19 libmcrypt \
20 bzip2 \
21 nmap \
22 libpcap \
23 tcpdump \
24 ebtables \
25 iw \
26 ethtool \
27 bc \
28 mesh-agent \
29 opensync \
30 openvswitch \
31 "
32
33BB_HASH_IGNORE_MISMATCH = "1"
34IMAGE_NAME[vardepsexclude] = "DATETIME"
35
36#ESDK-CHANGES
37do_populate_sdk_ext_prepend() {
38 builddir = d.getVar('TOPDIR')
39 if os.path.exists(builddir + '/conf/templateconf.cfg'):
40 with open(builddir + '/conf/templateconf.cfg', 'w') as f:
41 f.write('meta/conf\n')
42}
43
44sdk_ext_postinst_append() {
45 echo "ln -s $target_sdk_dir/layers/openembedded-core/meta-rdk $target_sdk_dir/layers/openembedded-core/../meta-rdk \n" >> $env_setup_script
46}
47
48PRSERV_HOST = "localhost:0"
49INHERIT += "buildhistory"
50BUILDHISTORY_COMMIT = "1"
51
52require image-exclude-files.inc
53
54remove_unused_file() {
55 for i in ${REMOVED_FILE_LIST} ; do rm -rf ${IMAGE_ROOTFS}/$i ; done
56}
57
58ROOTFS_POSTPROCESS_COMMAND_append = "remove_unused_file; "