developer | ceb0a14 | 2022-12-16 15:29:19 +0800 | [diff] [blame] | 1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" |
| 2 | |
| 3 | SRC_URI_append = " \ |
developer | 783a8a6 | 2024-01-17 12:34:31 +0800 | [diff] [blame^] | 4 | file://001-fix-64bit-build-error.patch;apply=no \ |
| 5 | file://002-change-scan-interface-name-prefix.patch;apply=no \ |
developer | ceb0a14 | 2022-12-16 15:29:19 +0800 | [diff] [blame] | 6 | " |
| 7 | |
| 8 | do_filogic_patches() { |
| 9 | cd ${S} |
| 10 | if [ ! -e patch_applied ]; then |
| 11 | for i in ${WORKDIR}/*.patch; do patch -p1 < $i; done |
| 12 | touch patch_applied |
| 13 | fi |
| 14 | } |
| 15 | addtask filogic_patches after do_unpack before do_configure |
| 16 | |
| 17 | do_install_append () { |
| 18 | install -d ${D}${systemd_unitdir}/system |
| 19 | install -D -m 0644 ${S}/scripts/RdkEasyMeshController.service ${D}${systemd_unitdir}/system/RdkEasyMeshController.service |
| 20 | } |
| 21 | |
| 22 | SYSTEMD_SERVICE_${PN} += "RdkEasyMeshController.service" |
| 23 | FILES_${PN}_append += "${systemd_unitdir}/system/RdkEasyMeshController.service" |
| 24 | |
| 25 | |