blob: 36893f8c11828b086cb10717ec24031be15fb2ba [file] [log] [blame]
developerceb0a142022-12-16 15:29:19 +08001FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI_append = " \
developer783a8a62024-01-17 12:34:31 +08004 file://001-fix-64bit-build-error.patch;apply=no \
5 file://002-change-scan-interface-name-prefix.patch;apply=no \
developerceb0a142022-12-16 15:29:19 +08006"
7
8do_filogic_patches() {
9 cd ${S}
10 if [ ! -e patch_applied ]; then
11 for i in ${WORKDIR}/*.patch; do patch -p1 < $i; done
12 touch patch_applied
13 fi
14}
15addtask filogic_patches after do_unpack before do_configure
16
17do_install_append () {
18 install -d ${D}${systemd_unitdir}/system
19 install -D -m 0644 ${S}/scripts/RdkEasyMeshController.service ${D}${systemd_unitdir}/system/RdkEasyMeshController.service
20}
21
22SYSTEMD_SERVICE_${PN} += "RdkEasyMeshController.service"
23FILES_${PN}_append += "${systemd_unitdir}/system/RdkEasyMeshController.service"
24
25