blob: c2f40b66e3145fec8b4ad1409b4b22ee7f996be3 [file] [log] [blame]
developer15a43312022-04-12 11:23:23 +08001inherit rdk-image
2
3IMAGE_FEATURES_remove = "read-only-rootfs"
4
5SYSTEMD_TOOLS = "systemd-analyze systemd-bootchart"
6# systemd-bootchart doesn't currently build with musl libc
7SYSTEMD_TOOLS_remove_libc-musl = "systemd-bootchart"
8
developer3d785cd2022-05-05 16:20:47 +08009IMAGE_INSTALL += " packagegroup-filogic-core \
developer15a43312022-04-12 11:23:23 +080010 ${SYSTEMD_TOOLS} \
developer15a43312022-04-12 11:23:23 +080011 network-hotplug \
12 libmcrypt \
developer3d785cd2022-05-05 16:20:47 +080013 coreutils \
14 util-linux-readprofile \
15 iputils \
16 bc \
17 python-core \
18 dosfstools \
19 pptp-linux \
20 rp-pppoe \
developer15a43312022-04-12 11:23:23 +080021 "
22
23BB_HASH_IGNORE_MISMATCH = "1"
24IMAGE_NAME[vardepsexclude] = "DATETIME"
25
26#ESDK-CHANGES
27do_populate_sdk_ext_prepend() {
28 builddir = d.getVar('TOPDIR')
29 if os.path.exists(builddir + '/conf/templateconf.cfg'):
30 with open(builddir + '/conf/templateconf.cfg', 'w') as f:
31 f.write('meta/conf\n')
32}
33
34sdk_ext_postinst_append() {
35 echo "ln -s $target_sdk_dir/layers/openembedded-core/meta-rdk $target_sdk_dir/layers/openembedded-core/../meta-rdk \n" >> $env_setup_script
36}
37
38PRSERV_HOST = "localhost:0"
39INHERIT += "buildhistory"
40BUILDHISTORY_COMMIT = "1"
41
42
43
44require image-exclude-files.inc
45
46remove_unused_file() {
47 for i in ${REMOVED_FILE_LIST} ; do rm -rf ${IMAGE_ROOTFS}/$i ; done
48}
49
50ROOTFS_POSTPROCESS_COMMAND_append = "remove_unused_file; "