developer | 15a4331 | 2022-04-12 11:23:23 +0800 | [diff] [blame] | 1 | inherit rdk-image |
| 2 | |
| 3 | IMAGE_FEATURES_remove = "read-only-rootfs" |
| 4 | |
| 5 | SYSTEMD_TOOLS = "systemd-analyze systemd-bootchart" |
| 6 | # systemd-bootchart doesn't currently build with musl libc |
| 7 | SYSTEMD_TOOLS_remove_libc-musl = "systemd-bootchart" |
| 8 | |
developer | 3d785cd | 2022-05-05 16:20:47 +0800 | [diff] [blame] | 9 | IMAGE_INSTALL += " packagegroup-filogic-core \ |
developer | 15a4331 | 2022-04-12 11:23:23 +0800 | [diff] [blame] | 10 | ${SYSTEMD_TOOLS} \ |
developer | 15a4331 | 2022-04-12 11:23:23 +0800 | [diff] [blame] | 11 | network-hotplug \ |
| 12 | libmcrypt \ |
developer | 3d785cd | 2022-05-05 16:20:47 +0800 | [diff] [blame] | 13 | coreutils \ |
| 14 | util-linux-readprofile \ |
| 15 | iputils \ |
| 16 | bc \ |
| 17 | python-core \ |
| 18 | pptp-linux \ |
| 19 | rp-pppoe \ |
developer | 60f0c3a | 2022-04-28 17:10:17 +0800 | [diff] [blame] | 20 | procps \ |
developer | 15a4331 | 2022-04-12 11:23:23 +0800 | [diff] [blame] | 21 | " |
| 22 | |
| 23 | BB_HASH_IGNORE_MISMATCH = "1" |
| 24 | IMAGE_NAME[vardepsexclude] = "DATETIME" |
| 25 | |
| 26 | #ESDK-CHANGES |
| 27 | do_populate_sdk_ext_prepend() { |
| 28 | builddir = d.getVar('TOPDIR') |
| 29 | if os.path.exists(builddir + '/conf/templateconf.cfg'): |
| 30 | with open(builddir + '/conf/templateconf.cfg', 'w') as f: |
| 31 | f.write('meta/conf\n') |
| 32 | } |
| 33 | |
| 34 | sdk_ext_postinst_append() { |
| 35 | echo "ln -s $target_sdk_dir/layers/openembedded-core/meta-rdk $target_sdk_dir/layers/openembedded-core/../meta-rdk \n" >> $env_setup_script |
| 36 | } |
| 37 | |
| 38 | PRSERV_HOST = "localhost:0" |
| 39 | INHERIT += "buildhistory" |
| 40 | BUILDHISTORY_COMMIT = "1" |
| 41 | |
| 42 | require image-exclude-files.inc |
| 43 | |
| 44 | remove_unused_file() { |
| 45 | for i in ${REMOVED_FILE_LIST} ; do rm -rf ${IMAGE_ROOTFS}/$i ; done |
| 46 | } |
| 47 | |
| 48 | ROOTFS_POSTPROCESS_COMMAND_append = "remove_unused_file; " |