developer | 15a4331 | 2022-04-12 11:23:23 +0800 | [diff] [blame^] | 1 | do_install_append() { |
| 2 | cp -Rfp ${B}/scripts/ ${STAGING_KERNEL_BUILDDIR}/ |
| 3 | install -d ${D}${includedir} |
| 4 | install -m 0644 ${B}/include/generated/autoconf.h ${D}${includedir}/autoconf.h |
| 5 | } |
| 6 | |
| 7 | sysroot_stage_all_append () { |
| 8 | install -d ${SYSROOT_DESTDIR}${includedir} |
| 9 | install -m 0644 ${D}${includedir}/autoconf.h ${SYSROOT_DESTDIR}${includedir}/autoconf.h |
| 10 | } |
| 11 | |
| 12 | |
| 13 | PACKAGES += "kernel-autoconf" |
| 14 | PROVIDES += "kernel-autoconf" |
| 15 | |
| 16 | FILES_kernel-autoconf = "${includedir}/autoconf.h" |