developer | 6fe1116 | 2022-04-15 15:55:45 +0800 | [diff] [blame] | 1 | SUMMARY = "An program to read/write from/to phy from userspace" |
| 2 | SECTION = "applications" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=c188eeeb69c0a05d0545816f1458a0c9" |
| 5 | |
| 6 | S = "${WORKDIR}" |
| 7 | |
| 8 | SRC_URI = " \ |
| 9 | file://COPYING \ |
| 10 | file://mii_mgr.c \ |
| 11 | file://mii_mgr.h \ |
| 12 | " |
| 13 | |
| 14 | do_compile() { |
| 15 | ${CC} ${LDFLAGS} mii_mgr.c -o mii_mgr |
| 16 | } |
| 17 | |
| 18 | do_install() { |
| 19 | install -d ${D}${sbindir} |
| 20 | install -m 0755 ${WORKDIR}/mii_mgr ${D}${sbindir} |
| 21 | install -m 0755 ${WORKDIR}/mii_mgr ${D}${sbindir}/mii_mgr_cl45 |
| 22 | } |