blob: fa68388ab8c1e194d8c6c0040bd5ca2884259e24 [file] [log] [blame]
developer3dd27372022-07-12 11:04:12 +08001SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
2
3
4
5FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
developere499f142023-02-13 17:54:38 +08006SRC_URI += " file://fw_env.config \
7 file://fw_env_emmc.config \
8 "
developer3dd27372022-07-12 11:04:12 +08009
10
11
12
13
developer3dd27372022-07-12 11:04:12 +080014do_install_append () {
15 install -d ${D}${sysconfdir}
developere499f142023-02-13 17:54:38 +080016 if ${@bb.utils.contains('DISTRO_FEATURES','emmc','true','false',d)}; then
17 install -m 0644 ${WORKDIR}/fw_env_emmc.config ${D}${sysconfdir}/fw_env.config
18 else
19 install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
20 fi
developer3dd27372022-07-12 11:04:12 +080021}
22
23