blob: 71228f23075c6d9952e13519edcda71b077e8296 [file] [log] [blame]
developerd243af02023-12-21 14:49:33 +08001DESCRIPTION = "OpenWrt debug service"
2SECTION = "utils"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5
6SRC_URI = " \
7 git://git.openwrt.org/project/udebug.git;protocol=https \
8 file://udebug.config \
9 file://udebug.init \
10 file://COPYING;subdir=git \
11"
12
13SRCREV = "6d3f51f9fda706f0cf4732c762e4dbe8c21e12cf"
14PV = "git${SRCPV}"
15
16S = "${WORKDIR}/git"
17
18
19DEPENDS += "libnl-tiny libubox ubus ucode"
20
21INSANE_SKIP_${PN} += "file-rdeps dev-deps dev-so"
22FILES_SOLIBSDEV = ""
23
24FILES_${PN}-dev = "${includedir}/*"
25FILES_${PN} = "${bindir}/* ${libdir}/*.so* ${libdir}/ucode/*"
26
27inherit cmake pkgconfig python3native
28
29