blob: b1ad94dd25131366408c97ac9cd675e6bdcf5aed [file] [log] [blame]
developerd33b8962022-11-18 14:37:27 +08001SUMMARY = "Marvell Ethernet firmware files"
2DESCRIPTION = "Firmware for Marvell AQR113C. "
3
4LICENSE = "CLOSED"
5
developer7b3485f2024-04-26 17:44:36 +08006SRC_URI = " \
7 file://Rhe-05.06-Candidate7-AQR_Mediatek_23B_StartOff_ID45623_VER36657.cld \
8 file://Rhe-05.06-Candidate9-AQR_Mediatek_23B_P5_ID45824_LCLVER1.cld\
developer0caf1462024-05-31 18:09:32 +08009 file://AQR-G4_v5.7.0-AQR_EVB_Generic_X3410_StdCfg_MDISwap_USX_ID46316_VER2148.cld \
developer7b3485f2024-04-26 17:44:36 +080010"
developerd33b8962022-11-18 14:37:27 +080011
12S = "${WORKDIR}"
13
14inherit allarch
15
16do_install() {
17 install -d ${D}/${base_libdir}/firmware/
developer96ffa632023-03-29 11:55:43 +080018 install -m 644 ${WORKDIR}/Rhe-05.06-Candidate9-AQR_Mediatek_23B_P5_ID45824_LCLVER1.cld ${D}${base_libdir}/firmware/
developer7b3485f2024-04-26 17:44:36 +080019 install -m 644 ${WORKDIR}/Rhe-05.06-Candidate7-AQR_Mediatek_23B_StartOff_ID45623_VER36657.cld ${D}${base_libdir}/firmware/
developer0caf1462024-05-31 18:09:32 +080020 install -m 644 ${WORKDIR}/AQR-G4_v5.7.0-AQR_EVB_Generic_X3410_StdCfg_MDISwap_USX_ID46316_VER2148.cld ${D}${base_libdir}/firmware/
developerd33b8962022-11-18 14:37:27 +080021}
22
developer7b3485f2024-04-26 17:44:36 +080023FILES_${PN} += "${base_libdir}/firmware/"
developerd33b8962022-11-18 14:37:27 +080024
25# Make marvell-eth-firmware depend on all of the split-out packages.
26python populate_packages_prepend () {
27 firmware_pkgs = oe.utils.packages_filter_out_system(d)
28 d.appendVar('RDEPENDS_marvell-eth-firmware', ' ' + ' '.join(firmware_pkgs))
29}