blob: 08f401d98ebae79a68babb9f2e0b26b550f5fb7d [file] [log] [blame]
developerbc262d52022-06-27 19:47:13 +08001# Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "OpenWrt system message/RPC bus"
5HOMEPAGE = "http://git.openwrt.org/?p=project/libubox.git;a=summary"
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://ubusd.c;beginline=1;endline=12;md5=1b6a7aecd35bdd25de35da967668485d"
8SECTION = "base"
9DEPENDS = "json-c libubox"
10
11SRC_URI = "git://git.openwrt.org/project/ubus.git"
12
13SRCREV = "4fc532c8a55ba8217ad67d7fd47c5eb9a8aba044"
14PV = "1.0.0+git${SRCPV}"
15
16S = "${WORKDIR}/git"
17
18inherit cmake pkgconfig
19
20EXTRA_OECMAKE = "-DBUILD_EXAMPLES=OFF -DBUILD_LUA=OFF -DBUILD_STATIC=ON"
21
22do_install_append () {
23 install -dm 0755 ${D}/sbin
24 ln -s /usr/sbin/ubusd ${D}/sbin/ubusd
25}
26
27TOOLCHAIN = "gcc"