developer | a7f4aed | 2022-05-20 14:14:11 +0800 | [diff] [blame] | 1 | SUMMARY = "mtk factory read and write" |
| 2 | SECTION = "applications" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 5 | |
| 6 | S = "${WORKDIR}" |
| 7 | inherit systemd |
| 8 | |
| 9 | SRC_URI = " \ |
| 10 | file://COPYING \ |
| 11 | file://mtk_factory_rw.sh \ |
| 12 | file://init-MacAddr.sh \ |
| 13 | file://init-MacAddr.service \ |
| 14 | " |
| 15 | |
| 16 | SYSTEMD_PACKAGES = "${PN}" |
| 17 | SYSTEMD_SERVICE_${PN} = " init-MacAddr.service" |
| 18 | FILES_${PN} += "{systemd_unitdir}/system/init-MacAddr.service" |
| 19 | |
| 20 | do_install() { |
| 21 | install -d ${D}${sbindir} |
| 22 | install -m 0755 ${WORKDIR}/mtk_factory_rw.sh ${D}${sbindir} |
| 23 | install -m 0755 ${WORKDIR}/init-MacAddr.sh ${D}${sbindir} |
| 24 | install -d ${D}${systemd_unitdir}/system/ |
| 25 | install -m 0644 ${S}/init-MacAddr.service ${D}${systemd_unitdir}/system |
| 26 | } |