developer | 0fa096b | 2022-04-12 19:48:09 +0800 | [diff] [blame] | 1 | SUMMARY = "nl80211 based CLI configuration utility for wireless devices" |
| 2 | DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \ |
| 3 | wireless devices. It supports almost all new drivers that have been added \ |
| 4 | to the kernel recently. " |
| 5 | HOMEPAGE = "https://wireless.wiki.kernel.org/en/users/documentation/iw" |
| 6 | SECTION = "base" |
| 7 | LICENSE = "BSD-2-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774" |
| 9 | |
| 10 | DEPENDS = "libnl" |
| 11 | |
developer | 6caa5e2 | 2022-06-16 13:33:13 +0800 | [diff] [blame] | 12 | SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.xz \ |
developer | 0fa096b | 2022-04-12 19:48:09 +0800 | [diff] [blame] | 13 | file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \ |
| 14 | file://separate-objdir.patch \ |
| 15 | " |
| 16 | |
developer | 6caa5e2 | 2022-06-16 13:33:13 +0800 | [diff] [blame] | 17 | SRC_URI[sha256sum] = "f167bbe947dd53bb9ebc0c1dcef5db6ad73ac1d6084f2c6f9376c5c360cc4d4e" |
developer | 6b200c7 | 2022-06-15 19:48:25 +0800 | [diff] [blame] | 18 | |
| 19 | FILESEXTRAPATHS_prepend := "${THISDIR}/patches:" |
| 20 | require patches/patches.inc |
developer | 0fa096b | 2022-04-12 19:48:09 +0800 | [diff] [blame] | 21 | |
| 22 | inherit pkgconfig |
| 23 | |
| 24 | EXTRA_OEMAKE = "\ |
| 25 | -f '${S}/Makefile' \ |
| 26 | \ |
| 27 | 'PREFIX=${prefix}' \ |
| 28 | 'SBINDIR=${sbindir}' \ |
| 29 | 'MANDIR=${mandir}' \ |
| 30 | " |
| 31 | |
| 32 | do_install() { |
| 33 | oe_runmake 'DESTDIR=${D}' install |
| 34 | } |