developer | f0fd705 | 2023-08-14 20:23:42 +0800 | [diff] [blame] | 1 | DESCRIPTION = "Tiny scripting and templating language" |
| 2 | SECTION = "lang" |
| 3 | LICENSE_NAME = "ISC" |
| 4 | LICENSE = "${LICENSE_NAME}" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b42eb47dc3802282b0d1be1bc8f5336c" |
| 6 | |
| 7 | SRC_URI = " \ |
| 8 | git://git@github.com/jow-/ucode.git;protocol=https \ |
developer | f0fd705 | 2023-08-14 20:23:42 +0800 | [diff] [blame] | 9 | " |
| 10 | |
developer | e92ee3c | 2023-10-25 17:01:28 +0800 | [diff] [blame] | 11 | SRCREV = "07c03173d4e6a30953f92fa88ed29b0b956c9106" |
developer | f0fd705 | 2023-08-14 20:23:42 +0800 | [diff] [blame] | 12 | PV = "git${SRCPV}" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | |
| 17 | DEPENDS += "libnl-tiny libubox ubus uci" |
| 18 | |
| 19 | INSANE_SKIP_${PN} += "file-rdeps dev-deps dev-so" |
| 20 | FILES_SOLIBSDEV = "" |
| 21 | |
| 22 | FILES_${PN}-dev = "${includedir}/*" |
developer | e92ee3c | 2023-10-25 17:01:28 +0800 | [diff] [blame] | 23 | FILES_${PN} = "${bindir}/* ${libdir}/libucode.so* ${libdir}/ucode/*" |
developer | f0fd705 | 2023-08-14 20:23:42 +0800 | [diff] [blame] | 24 | |
| 25 | inherit cmake pkgconfig python3native |
| 26 | |
| 27 | |
| 28 | EXTRA_OECMAKE = "\ |
| 29 | -DFS_SUPPORT=ON \ |
| 30 | -DMATH_SUPPORT=ON \ |
| 31 | -DNL80211_SUPPORT=ON \ |
| 32 | -DRESOLV_SUPPORT=ON \ |
| 33 | -DRTNL_SUPPORT=ON \ |
| 34 | -DSTRUCT_SUPPORT=ON \ |
developer | e92ee3c | 2023-10-25 17:01:28 +0800 | [diff] [blame] | 35 | -DUBUS_SUPPORT=ON \ |
developer | f0fd705 | 2023-08-14 20:23:42 +0800 | [diff] [blame] | 36 | -DUCI_SUPPORT=ON \ |
| 37 | -DULOOP_SUPPORT=ON \ |
| 38 | " |
| 39 | |