blob: 80666fae532e9fad19bef482f07e0f597dd543b4 [file] [log] [blame]
developer930b9e52022-04-15 15:55:45 +08001SUMMARY = "An program to read/write from/to a pci device from userspace"
2SECTION = "applications"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c188eeeb69c0a05d0545816f1458a0c9"
5
6S = "${WORKDIR}"
7
8SRC_URI = " \
9 file://COPYING \
10 file://regs.c \
11 "
12
13do_compile() {
14 ${CC} ${CFLAGS} ${LDFLAGS} regs.c -o regs
15}
16
17do_install() {
18 install -d ${D}${base_bindir}
19 install -m 0755 ${WORKDIR}/regs ${D}${base_bindir}
20}