developer | 8c4b8ab | 2023-02-09 10:37:49 +0800 | [diff] [blame] | 1 | SUMMARY = " a collection of userspace utilities for the ksmbd kernel server" |
| 2 | SECTION = "Applications" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
developer | 3dfd254 | 2023-02-07 10:54:54 +0800 | [diff] [blame] | 5 | |
| 6 | inherit autotools pkgconfig systemd |
| 7 | |
| 8 | DEPENDS += "ksmbd libnl glib-2.0" |
| 9 | |
| 10 | SRC_URI = " \ |
| 11 | git://git@github.com/cifsd-team/ksmbd-tools.git;protocol=https;tag=${PV} \ |
| 12 | file://smb.conf \ |
| 13 | file://ksmbd.service \ |
developer | 8c4b8ab | 2023-02-09 10:37:49 +0800 | [diff] [blame] | 14 | file://COPYING;subdir=git \ |
developer | 3dfd254 | 2023-02-07 10:54:54 +0800 | [diff] [blame] | 15 | " |
| 16 | |
| 17 | |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | #EXTRA_OECONF += "GLIB_LIBS="${STAGING_LIBDIR}/libglib-2.0.a"" |
| 22 | EXTRA_OECONF_append = " --disable-shared --enable-static" |
| 23 | CFLAGS_prepend = " \ |
| 24 | -D_GNU_SOURCE \ |
| 25 | -I${STAGING_INCDIR}/libnl3 \ |
| 26 | -I${STAGING_INCDIR}/glib-2.0 \ |
| 27 | -I${STAGING_LIBDIR}/glib-2.0/include \ |
| 28 | -I${S} \ |
| 29 | -ffunction-sections -fdata-sections -flto \ |
| 30 | " |
| 31 | LDFLAGS += " -lglib-2.0" |
| 32 | |
| 33 | SYSTEMD_PACKAGES = "${PN}" |
| 34 | SYSTEMD_SERVICE_${PN} = " ksmbd.service" |
| 35 | FILES_${PN} += "{systemd_unitdir}/system/ksmbd.service" |
| 36 | |
| 37 | do_install_append () { |
| 38 | install -d ${D}${systemd_unitdir}/system/ |
| 39 | install -m 0644 ${WORKDIR}/ksmbd.service ${D}${systemd_unitdir}/system |
| 40 | install -d ${D}/etc/ksmbd |
| 41 | install -m 0644 ${WORKDIR}/smb.conf ${D}/etc/ksmbd |
| 42 | install -m 0644 ${S}//Documentation/configuration.txt ${D}/etc/ksmbd |
| 43 | } |