blob: dfb91c9c69194ae4285ff39864da5af3db6c1b34 [file] [log] [blame]
developerd33b8962022-11-18 14:37:27 +08001SUMMARY = "Marvell Ethernet firmware files"
2DESCRIPTION = "Firmware for Marvell AQR113C. "
3
4LICENSE = "CLOSED"
5
developer96ffa632023-03-29 11:55:43 +08006SRC_URI = "file://Rhe-05.06-Candidate9-AQR_Mediatek_23B_P5_ID45824_LCLVER1.cld"
developerd33b8962022-11-18 14:37:27 +08007
8S = "${WORKDIR}"
9
10inherit allarch
11
12do_install() {
13 install -d ${D}/${base_libdir}/firmware/
developer96ffa632023-03-29 11:55:43 +080014 install -m 644 ${WORKDIR}/Rhe-05.06-Candidate9-AQR_Mediatek_23B_P5_ID45824_LCLVER1.cld ${D}${base_libdir}/firmware/
developerd33b8962022-11-18 14:37:27 +080015}
16
developer96ffa632023-03-29 11:55:43 +080017FILES_${PN} += "${base_libdir}/firmware/Rhe-05.06-Candidate9-AQR_Mediatek_23B_P5_ID45824_LCLVER1.cld"
developerd33b8962022-11-18 14:37:27 +080018
19# Make marvell-eth-firmware depend on all of the split-out packages.
20python populate_packages_prepend () {
21 firmware_pkgs = oe.utils.packages_filter_out_system(d)
22 d.appendVar('RDEPENDS_marvell-eth-firmware', ' ' + ' '.join(firmware_pkgs))
23}