developer | 6040b46 | 2022-07-01 13:42:44 +0800 | [diff] [blame^] | 1 | DESCRIPTION = "OpenWrt AP roaming assist daemon" |
| 2 | HOMEPAGE = "https://git.openwrt.org/project/usteer.git" |
| 3 | LICENSE = "GPL-2.0-only" |
| 4 | LIC_FILES_CHKSUM = "file://README.md;md5=26019f6caa040c198cccce12a534366f" |
| 5 | SECTION = "kernel/userland" |
| 6 | DEPENDS = "json-c libubox ubus libnl-tiny libpcap" |
| 7 | |
| 8 | SRC_URI = "git://git.openwrt.org/project/usteer.git" |
| 9 | |
| 10 | SRCREV = "${AUTOREV}" |
| 11 | PV = "git${SRCPV}" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit cmake pkgconfig |
| 16 | |
| 17 | do_install_append () { |
| 18 | install -dm 0755 ${D}/sbin |
| 19 | ln -s /usr/sbin/usteerd ${D}/sbin/usteerd |
| 20 | } |
| 21 | |
| 22 | FILESEXTRAPATHS_prepend := "${THISDIR}/files:" |
| 23 | |
| 24 | inherit ${@d.getVar('DISTRO', True) == 'rdk' and 'systemd' or 'base'} |
| 25 | |
| 26 | SRC_URI_append_rdk += "\ |
| 27 | file://usteer.service \ |
| 28 | " |
| 29 | SYSTEMD_AUTO_ENABLE_${PN} = "disable" |
| 30 | SYSTEMD_SERVICE_${PN}_rdk = "usteer.service" |
| 31 | |
| 32 | do_install_append_rdk() { |
| 33 | # Install systemd unit files |
| 34 | install -d ${D}${systemd_unitdir}/system |
| 35 | install -m 0644 ${WORKDIR}/usteer.service ${D}${systemd_unitdir}/system |
| 36 | sed -i -e 's,@SBINDIR@,${sbindir},g' \ |
| 37 | ${D}${systemd_unitdir}/system/usteer.service |
| 38 | } |
| 39 | |