blob: c233ebeff76da1596a37a2bab4712c1bf73b3ae4 [file] [log] [blame]
developer930b9e52022-04-15 15:55:45 +08001SUMMARY = "An program to read/write from/to phy from userspace"
2SECTION = "applications"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c188eeeb69c0a05d0545816f1458a0c9"
5
developer930b9e52022-04-15 15:55:45 +08006SRC_URI = " \
developer270fdef2022-11-03 16:01:43 +08007 file://COPYING;subdir=git/src \
8 file://src;subdir=git \
9 file://fix-rdkb-wan-get-status-fail.patch \
developer930b9e52022-04-15 15:55:45 +080010 "
11
developer270fdef2022-11-03 16:01:43 +080012S = "${WORKDIR}/git/src"
13
developer930b9e52022-04-15 15:55:45 +080014do_compile() {
15 ${CC} ${LDFLAGS} mii_mgr.c -o mii_mgr
16}
17
18do_install() {
19 install -d ${D}${sbindir}
developer270fdef2022-11-03 16:01:43 +080020 install -m 0755 ${S}/mii_mgr ${D}${sbindir}
21 install -m 0755 ${S}/mii_mgr ${D}${sbindir}/mii_mgr_cl45
developer930b9e52022-04-15 15:55:45 +080022}