blob: 15ef36002e1312a343c71d0449693924d5f98bfc [file] [log] [blame]
developer7ca0cdb2022-11-18 13:20:18 +08001# Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Library for accessing wireless device drivers"
5HOMEPAGE = "http://git.openwrt.org/?p=project/iwinfo.git;a=summary"
6LICENSE = "GPL-2.0-only"
7LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
8SECTION = "base"
9DEPENDS += "uci lua ubus libnl-tiny"
10
developer42c7a432024-07-12 14:39:29 +080011SRCREV = "215820132b943b700d56441ecbd5a4efa09edc7c"
developer7ca0cdb2022-11-18 13:20:18 +080012
13SRC_URI = "git://git.openwrt.org/project/iwinfo.git;branch=master \
14 file://0002-fix-order-of-linker-cmdline-to-help-linking.patch \
15 file://0003-Replace-typedef-loaL_reg-with-luaL_Reg.patch \
16 "
17
18S = "${WORKDIR}/git"
19
20CFLAGS += "-fPIC -D_GNU_SOURCE"
21CFLAGS += " -I=${includedir}/libnl-tiny "
22# iwinfo breaks with parallel make
23PARALLEL_MAKE = ""
24
25EXTRA_OEMAKE = "\
26 'BACKENDS=nl80211' \
27 'SOVERSION=openwrt' \
28"
29
30do_install() {
31 install -D -m 0755 ${B}/libiwinfo.so ${D}${libdir}/libiwinfo.so
developer93e97202024-01-17 12:29:44 +080032 install -D -m 0755 ${B}/iwinfo.so ${D}${libdir}/lua/iwinfo.so
33 install -D -m 0755 ${B}/iwinfo ${D}${bindir}/iwinfo
developer7ca0cdb2022-11-18 13:20:18 +080034 install -D -m 0644 ${S}/include/iwinfo.h ${D}${includedir}/iwinfo.h
35 install -D -m 0644 ${S}/include/iwinfo/utils.h ${D}${includedir}/iwinfo/utils.h
36}
37
38FILES_SOLIBSDEV = ""
developer93e97202024-01-17 12:29:44 +080039FILES_${PN} += "${libdir}/libiwinfo.so ${libdir}/lua/iwinfo.so"