blob: 82414774436977067b07108aca2b6559aba82eed [file] [log] [blame]
developer9d5ead82022-04-12 19:48:09 +08001SUMMARY = "nl80211 based CLI configuration utility for wireless devices"
2DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \
3wireless devices. It supports almost all new drivers that have been added \
4to the kernel recently. "
5HOMEPAGE = "https://wireless.wiki.kernel.org/en/users/documentation/iw"
6SECTION = "base"
7LICENSE = "BSD-2-Clause"
8LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
9
10DEPENDS = "libnl"
11
developer42b63282022-06-16 13:33:13 +080012SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.xz \
developer9d5ead82022-04-12 19:48:09 +080013 file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \
14 file://separate-objdir.patch \
15"
16
developer42b63282022-06-16 13:33:13 +080017SRC_URI[sha256sum] = "f167bbe947dd53bb9ebc0c1dcef5db6ad73ac1d6084f2c6f9376c5c360cc4d4e"
developer2e1f7802022-06-15 19:48:25 +080018
19FILESEXTRAPATHS_prepend := "${THISDIR}/patches:"
20require patches/patches.inc
developer9d5ead82022-04-12 19:48:09 +080021
22inherit pkgconfig
23
24EXTRA_OEMAKE = "\
25 -f '${S}/Makefile' \
26 \
27 'PREFIX=${prefix}' \
28 'SBINDIR=${sbindir}' \
29 'MANDIR=${mandir}' \
30"
31
32do_install() {
33 oe_runmake 'DESTDIR=${D}' install
34}